(CoreElec 9.2.6 / 9.2.7) Library scanning slow to non-working

Hi there.

It seems that there is some kind of issue with my Mini M8s II CoreElec installation, regarding the Library Scanning. The issue had surfaced with CE 9.2.6, too.
Here is some info:

  • I installed 9.2.6 from the start (no restored backup, only a pasting of my previous passwords.xml and the SMB sources.xml within the Usedata folder). The installation of 9.2.6 was done on a different newly formatted microSD card. The card is a 16 GB Lexar U1 Micro SD. After a few days 9.2.7 was released so I updated. I do remember not having this issue with 9.2.5 and prior.

  • My SMB shares are two USB hard disks plugged to my Fritz Router.

  • I have enabled scanning at startup. It seems like it starts the scanning and it stays at 0%. If I go manually to “update video library” sometimes it does nothing and other times it starts scanning but it is very slow. I have tried with 3-4 different metadata services (TVDM, The Movie Database, The Movies Database Python, etc). Last night I cleaned the library and left it all night to scan from the beginning.
    When I woke up it still hadn’t scan all the library. I seemed like it was stuck at 100% of some TV Series.

  • I also tried with disabling scanning at start up. Didn’t help. I also have Watchdog add on installed. Does not help.

  • In both Windows 10 Kodi and CE Kodi I have SMBv2 as minimum and SMBv3 as max.

  • With my CE box I have tried with lan cable connected directy to my box’s 100 ethernet port, and I have also tries with my CE supported TP-Link UE300 USB 3.0 to LAN adapter (Realtek 8153 chipset). No change there. Same issue.

  • My Windows PC Kodi 18.9 sees the same SMB sources and has no issues at all ! It always scans without issues when Kodi starts. It also works fine when I manually go to “update video library”.

So it seems that the problem is with my CoreElec intallation only, but I cannot find what’s wrong.

I do see some errors within the Kodi log but I cannot understand what they mean. Here is a sample:

2021-03-20 08:45:34.960 T:4022330240   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20A%20R%20C%20H%20I%20V%20E%20S:
2021-03-20 08:45:34.960 T:4022330240   ERROR: Run: Unable to parse web site
2021-03-20 08:45:35.061 T:4022330240   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20A%20R%20C%20H%20I%20V%20E%20S:
2021-03-20 08:45:35.061 T:4022330240   ERROR: Run: Unable to parse web site
2021-03-20 08:45:35.062 T:4022330240 WARNING: No information found for item 'smb://192.168.178.1/FRITZ.NAS/INTENSO/Video/TV Series/T V S   A R C H I V E S/', it won't be added to the library.
2021-03-20 08:45:35.718 T:4022330240   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20W%20A%20T%20C%20H%20I%20N%20G:
2021-03-20 08:45:35.719 T:4022330240   ERROR: Run: Unable to parse web site
2021-03-20 08:45:35.809 T:4022330240   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20W%20A%20T%20C%20H%20I%20N%20G:
2021-03-20 08:45:35.809 T:4022330240   ERROR: Run: Unable to parse web site
2021-03-20 08:45:35.810 T:4022330240 WARNING: No information found for item 'smb://192.168.178.1/FRITZ.NAS/INTENSO/Video/TV Series/T V S   W A T C H I N G/', it won't be added to the library.
2021-03-20 08:45:41.490 T:3814249344  NOTICE: Skin Helper Service --> Skin Helper Service version 1.1.32 started

log-2021-03-20-07.07.10.zip (365.1 KB)

Full Kodi’s log attached.

https error 404 is page not found. So, the parser didn’t find anything to parse.

Yeah, but I don’t know what that could mean.

So I restarted CE and I managed to get it to scan the library from the start with The Movies Database Python scrapper. I got an error at one point, and the message said to look at the log. But I haven’t found anything.

I let it complete the scanning. It took more than an hour to scan everything.
Then I rebooted CE to see of it will scan for new contents.

Here are some errors / warnings in the log:

2021-03-20 13:00:17.984 T:4091658256 ERROR: DBus error: org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files

2021-03-20 13:00:18.146 T:4091658256   ERROR: GetString: error reading /storage/.kodi/userdata/disp_cap
2021-03-20 13:00:18.146 T:4091658256   ERROR: GetString: error reading /sys/class/amhdmitx/amhdmitx0/vesa_cap
2021-03-20 13:00:18.146 T:4091658256   ERROR: GetString: error reading /sys/class/amhdmitx/amhdmitx0/custom_mode
2021-03-20 13:00:18.146 T:4091658256   ERROR: GetString: error reading /storage/.kodi/userdata/disp_add
2021-03-20 13:00:18.146 T:4091658256   ERROR: GetString: error reading /run/disp_add


2021-03-20 13:00:30.543 T:3987919744   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20A%20R%20C%20H%20I%20V%20E%20S:
2021-03-20 13:00:30.543 T:3987919744   ERROR: Run: Unable to parse web site
2021-03-20 13:00:30.544 T:3987919744 WARNING: No information found for item 'smb://192.168.178.1/FRITZ.NAS/INTENSO/Video/TV Series/T V S   A R C H I V E S/', it won't be added to the library.

2021-03-20 13:00:31.443 T:3987919744   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20W%20A%20T%20C%20H%20I%20N%20G:
2021-03-20 13:00:31.443 T:3987919744   ERROR: Run: Unable to parse web site

2021-03-20 13:00:47.282 T:3305968512  NOTICE: script.module.metadatautils --> Rate limiter active for themoviedb.org - delaying request with 1 seconds - Configure a personal API key in the settings to get rid of this message and the delay.
2021-03-20 13:00:47.925 T:3945186176   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20A%20R%20C%20H%20I%20V%20E%20S:
2021-03-20 13:00:47.926 T:3945186176   ERROR: Run: Unable to parse web site

2021-03-20 13:00:48.884 T:3945186176   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20A%20R%20C%20H%20I%20V%20E%20S:
2021-03-20 13:00:48.884 T:3945186176   ERROR: Run: Unable to parse web site
2021-03-20 13:00:48.885 T:3945186176 WARNING: No information found for item 'smb://192.168.178.1/FRITZ.NAS/INTENSO/Video/TV Series/T V S   A R C H I V E S/', it won't be added to the library.

2021-03-20 13:00:51.515 T:3945186176   ERROR: CCurlFile::Open failed with code 404 for https://api.thetvdb.com/search/series?name=T%20V%20S%20%20%20W%20A%20T%20C%20H%20I%20N%20G:
2021-03-20 13:00:51.516 T:3945186176   ERROR: Run: Unable to parse web site
2021-03-20 13:00:51.517 T:3945186176 WARNING: No information found for item 'smb://192.168.178.1/FRITZ.NAS/INTENSO/Video/TV Series/T V S   W A T C H I N G/', it won't be added to the library.

TBH I don’t know how to interpret these errors and warnings.
How come the Windows PC Kodi has no errors scanning and finding everything while the CE installation brings out these errors. Is there anything I’m doing wrong ?

What worries me the most is these errors:

2021-03-20 13:00:48.885 T:3945186176 WARNING: No information found for item 'smb://192.168.178.1/FRITZ.NAS/INTENSO/Video/TV Series/T V S   A R C H I V E S/', it won't be added to the library.

and

2021-03-20 13:00:51.517 T:3945186176 WARNING: No information found for item 'smb://192.168.178.1/FRITZ.NAS/INTENSO/Video/TV Series/T V S   W A T C H I N G/', it won't be added to the library.

Does this error mean that no NEW content has been found ? Or that no content at all has been found?
If it’s the second, then something is really wrong here because these two folders are the ones that contain all my TV Series video files.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice