CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - FunHouse builds

Read this topic to get more info about this

Thanks, but that has nothing to do with HDMI output modes.

I’m getting an occasional Ethernet lockups on Le Potato, something similar to this. Happens during file transfer over LAN and sometimes during live tv streaming. No idea how to reliably reproduce, seems random.

Agree, but explains the main use for 4:2:2 and why it’s not used and supported on any Kodi platform.

Thanks, I will see if I can manage to reproduce this.

2 posts were split to a new topic: Possilbe patches to improve kodi

I encountered another, really bizarre issue. This time I can easily reproduce it.
A fast navigation in Kodi’s GUI makes my USB DVB tuner to completely lock up. The tuner will require a power cycle. The issue can be easily reproduced when scrolling the TV channel list really fast. I made a video of this. The tuner fails at 00:40.

The issue occur only when the output is set to 4K 50/60Hz. I can’t reproduce it with 1080p.

Does this only happen with the the Funhouse(or any other build based on the amlogic-ng-on-gxl branch) or does it happen with the current stable as well?

I didn’t test it with the current stable. I can test tomorrow if it can help with debugging this.

Scratch that, it also happens with 1080p. It looks like heavy GPU activity somehow interfere with the USB traffic and the tuner craps out.

I tried to change I/O scheduler from default noop to cfq and deadline but that didn’t make any difference.

CoreELEC funhouse_2024.6 - Release Notes

Changes since funhouse_2011.6:
• Update CoreELEC funhouse build to match CoreELEC 9.2.3 release
• Fix dtb for LePotato (The LePotato image should now work properly with 1gb model)
• Several minor fixes and improvements

Known Issue:
• Internal DVB support is still missing.
• Booting from sd card causes a delay in booting the device.
• There are probably numerous other like unfinished and odd things.


No changes for my noname S905X 1/8 box, can start it only in textmode. When do systemctl start kodi got kernel crash. But build from 15 Jan (with old 4.9 kernel from HK, before you start using amlogic 4.9.113) work ok.

I’ve discovered an easy method with no inconvenience related to the ng boot script.

Using my Mecool K1 Pro S905D 2gb / 16gb with CoreELEC 9.2.3 booting via SD Card

I flashed new funhouse_2024.6 ng image to a Corsair 64gb USB stick.
Removed the CE 9.2.3 SD Card

Inserted the USB stick with funhouse_2024.6
Toothpick reset for first ng bootup and it booted no problem.

I restored previous externally copied backup from my stable 9.2.3 SD Card image.
which worked.

I then powered off the box and inserted the SD Card with 9.2.3 image
Note: I did not remove the USB Stick

I powered on the box and it booted to my SD Card 9.2.3

I powered off the box
Removed the SD Card

Powered on and it booted to USB funhouse_2024.6 ng without having to Toothpick reset again.

So for those wanting to run these funhouse builds it is not that painfull. :grin:

Run the stable on an sd card or power off and pull out the sd card to boot NG Funhouse.

To explain it better the contents of aml_autoscript are saved to the env partition when pressing the reset button.

This partition is read by the bootloader at every boot up and contains the boot commands, that is why it is only needed once because once our modifications are saved then they are there forever unless you do a factory reset.

It seems the aml_autoscript commands tell the bootloader to try booting from SD Card first and the USB is ignored if BOTH are inserted at the same time.

EDIT UPDATE: It seems that this is not how the script works.
I just came home and cold booted with SD Card and USB stick inserted and it failed to boot with an error from trying to boot USB funhouse_2024.6 ng

So do not leave both SD Card and USB Stick inserted at the same time.
It’s hit or miss what happens. :grinning:

I removed the SD Card after power off and it booted properly (without Toothpick reset)

1 Like

Great job cdu13a got it running smoothly on a w95 s905w 1gb model box, so far the only issues are the following:

2.1 sound and above causes any video to stop.

Analog audio not working.

Slow boot time even when installed to internal.

Laggy UI when opening osd.

I’m no dev but if I can help somehow let me know.

Edit: Also the option to disable noise reduction is gone.

4.9 kernel behaves differently with Audio.
Set it to HDMI Multi Ch PCM audio device for HDMI and PCM for analog.
Make sure that sync playback to display option in Settings > Player > Videos is disabled.

Hi, already have sync playback to display disabled but I don’t see the option HDMI Multi Ch PCM anywere, can you pls point me in the right direction?

The audio config needs some work. I’ve not done anything with audio on CoreELEC so it’s a bit of a learning curve for me and might take a bit of time unless one of the other devs that have more experience handling audio stuff gets a chance to deal with it.

Hello, did installtointernal worked? I run this build on a X96 Mini (S905W), and would like to test this. Cheers!
PS: I’m aware that it is unsupported.

Got it working on a w95 s905w 1gb with ceemmc but remember it’s unsupported…

1 Like