CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - FunHouse builds

Ok. Nothing secret here. The device is Phicomm N1. Actually I tried 9.2.4.2 too and the result is same.

I compared the log when playing the same 4k HDR file between non-ng and ng versions:
non-ng version:
2020-08-22 00:30:51.132 T:4090634816 NOTICE: Whitelist search for: width: 3840, height: 2160, fps: 23.976, 3D: false
2020-08-22 00:30:51.133 T:4090634816 NOTICE: Display resolution ADJUST : 3840x2160 @ 23.98 - Full Screen (36) (weight: 0.000)
2020-08-22 00:30:51.554 T:4090634816 NOTICE: VideoPlayer: OnLostDisplay received
2020-08-22 00:30:51.554 T:4090634816 ERROR: GetString: error reading /sys/class/amhdmitx/amhdmitx0/custom_mode
2020-08-22 00:30:51.848 T:4090634816 NOTICE: VideoPlayer: OnResetDisplay received

ng version:
2020-08-21 23:12:17.929 T:4092355136 NOTICE: Whitelist search for: width: 3840, height: 2160, fps: 23.976, 3D: false
2020-08-21 23:12:17.930 T:4092355136 NOTICE: Display resolution ADJUST : 3840x2160 @ 23.98 - Full Screen (39) (weight: 0.000)
2020-08-21 23:12:18.154 T:4092355136 NOTICE: VideoPlayer: OnLostDisplay received
2020-08-21 23:12:18.155 T:4092355136 ERROR: GetString: error reading /sys/class/amhdmitx/amhdmitx0/custom_mode
2020-08-21 23:12:18.351 T:3403658112 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
2020-08-21 23:12:18.446 T:4092355136 NOTICE: VideoPlayer: OnResetDisplay received

There is one WARNING line with the ng verson:
2020-08-21 23:12:18.351 T:3403658112 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

After more testing, I have one correction. The 2nd problem is only with 4K HDR video file, not normal 4K video. So the problem is with 4K HDR. I tried both turning on/off the HDR to SDR conversion and the result is same.
Another issue, CE keeps waking up my TV through CEC. It turns on the TV immediately after I turn off my Sony TV while CE is running.

Sounds like your TV doesn’t like the 10bit input signal CE is outputting.
Try enabling the Force 4:2:2 Chroma in the CE settings and reboot, see if that helps.

This is about the HDR issue right?

It’s a TV issue, not HDR.
Could also be a bad HDMI cable, and/or bad configuration of your TV/AVR.

I tested with 4:2:2 option and the HDR video plays. But the video is quite ‘washed out’. There is no issue with my cable. Just my AVR doesn’t support HDR. But the non-ng version of CE plays fine with the HDR video without enabling this option. The HDR video played by the non-ng version looks dark on my TV and I believe that’s normal since my AVR doesn’t support HDR. But this is different with the ng version.

Correct, you will have to connect the box directly to the TV.

So something changed on outputing HDR videos between non-NG and NG versions right?
Any idea with the CEC issue?

I enabled libcec component log in kodi and got this when I turn off my TV:
2020-09-05 12:49:44.012 T:4093665856 NOTICE: OnSleep: Running sleep jobs
2020-09-05 12:49:44.157 T:4093665856 ERROR: Keymapping error: no such action ‘lirc.stop’ defined
2020-09-05 12:49:49.683 T:4093665856 ERROR: Keymapping error: no such action ‘lirc.start’ defined
2020-09-05 12:49:49.765 T:4093665856 NOTICE: OnWake: Running resume jobs
2020-09-05 12:49:49.816 T:4072747904 WARNING: Pulseaudio module module-allow-passthrough not loaded - opening PT devices might fail
2020-09-05 12:49:49.817 T:4072747904 NOTICE: Found 2 Lists of Devices
2020-09-05 12:49:49.817 T:4072747904 NOTICE: Enumerated ALSA devices:

CE turns my TV on after the OnWake. Any help?

Any updates or workarounds how we can install NG to 1GB box yet? Thanks.

Any news about NG builds on Android 6 + 1GB box?

Works on GTMEDIA GTC box with gxl_p212_2g.dtb

Ĵust a quick question: where did you get that Android version for the A95X A1? I may be stupid, but I can’t find any image for this device…

Sorry I do not remember and did not save the file. I think it was not specific for this device.

If anyone else ever comes across this: It worked for me with the factory Nexbox A95X Image from here:

2g-16g

Had no luck with some custom firmwares I tried, they all refused to boot from sd. The Android won’t have wifi, but I did not care a bit, as I just use this box for coreelec anyways. Was surprised as well that it worked, as it’s obviously not for the A95X A1 box…

Wonder if you’ve already tried this firmware on your box - seems to be quite compatible with many boxes:

Firstly, I would like to thank the devs for all of their great work on CoreELEC!

As for my situation:
I have an OTT A95X A1 1G/8G box (probably a clone), the one with the weird v2.0 motherboard and weird wifi. I had the 9.2.8 version installed into the internal emmc as an only os and it was working fine for a few years already. The original firmware was most probably 6.0 based.

I wanted to upgrade to the ng build. I have tried booting it, but it was freezing up after a few seconds after the boot into kodi. After some research, I was able to upgrade the device with an USB-A - USB-A cable and amlogic burning tool (v3.1.0) to the 7.1 firmware available in the above mentioned link (MEGA this is it if freaktab goes down again).

After upgrading, the bootlogo changed to the Nexbox one, Android was able to boot fine. To my surprise, even the Wi-Fi worked. I tried booting the ng build again - I pressed the button inside of the audio 3.5mm jack and kept it pressed until the coreelec logo showed up, anything less and it would boot into android; I had the flash drive in the USB slot closer to the front of the device. Afterwards, coreelec booted just fine, I installed it into the internal emmc and everything seems to be working fine for now. The device seems to be a little snappier, but I might just be imagining things.

Thanks so much! This also worked for my Eminent EM7680, which previously just bootlooped and kept crashing with 19.3. Here is what I did:

Booted into windows and downloaded NEXBOX-A95X_S905X_7.1_8189_8g1g_171118preview_SD_USB.rar and Tool_USB from that MEGA storage link. I hooked my hacked A-to-A USB cable between my laptop and the USB port closest to the SD card reader. I started the USB tool and held the reset while powering on the box. Then I could download the fie aml_upgrade_package.img to the box and in about 5 minutes it was done. After a reset of the box it took another five minutes before the Nexbox software was fully loaded. Inserting the SD card and rebooting, coreelec 19.3 was loading up nicely.

Hi @brupje, I am really glad that it helped someone. I had a pretty hard time finding the correct files, everything seemed to lead to rotten links :confused: Enjoy your fixed box :yum:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice