coreELEC boot error

Posting this for the first time and I am complete newbie, alien to IT world


  1. X96 Max Android Box with 4GB RAM & 64 GB ROM
  2. USB stick with 1GB storage for boot

Installation was fresh. burned using win32 disk imager. I did get coreELEC logo and immediately after that I got this error

###Starting debugging shell for boot step: mount _storage…type exit to quit ###
*** Error in mount_storage: mount_commin: Could not mount LABEL=STORAGE ***

Shall I use SD card instead of USB stick? USB stick was previously used for storing some data.
Please refer the attached pic.

coreELEC was download from below link

What could be the possible error?

Reburn the image with Rufus.

How big is this USB stick ?

That’s your problem. 1 GB

it’s a slim & flat USB stick.

Didn’t ask for physical dimensions which are irrelevant, but for size in Gigabytes :wink:

Oops…as is mentioned it’s 1GB only.:grinning:

8GB is the minimum for CE/Kodi installation. Most use 16GB, and heavy users need 32GB.

4 GB stick works fine for me.

2g would work for initial testing.

Had same issue with h96pro+ couldn’t get working with USB so switched to an SD card and it worked fine.

Finally how you solved the problem?

I have 2 x96max and one runs just fine, and I can’t boot the other one, I am having the same message of starting debuggin shell for boot step…