CoreELEC hijacking network

I have a Mecool M8S pro running CoreELEC, that is my tvheaded DVR. The problem that I have is that it hijacks my network master device. I have had this issue for at least a couple of years, even on LibreELEC, but no on OpenELEC running on a different device. I use the Windows LANscanner to see what devices is my network master.

What happens when it hijacks my network master, my networked devices no longer show up under windows explorer. Since I am constantly moving files back and forth between my networked devices, like my NAS’s, it is a pain when my devices disappear from my network.

I brought this subject up on a different forum with a different issue, and a couple of people of users told me what the issue is, but only the Dev’s here can fix it.

I hope you understand what I am talking about. I can post pictures if necessary. Anyway his is the conversation.

"I have one device that is running my Tvheadend DVR server under CoreELEC (minimal Linux distro), and it constantly hijacks my LAN master. As most of you know, one device on your network, becomes the master, I just learned this a couple of years ago. Anyway, when some of my other networked devices, like my NAS’s or other Windows computers are the master, all my devices are discoverable using Windows explorer. When , my CoreELEC box hijacks the “master”, no devices are discoverable from any of my Windows machines. Of course, Linux NEVER fails to discover the devices on my network, but I only use Windows on my desktop computer. I run Linux on some of my cheapie boxes connected to my different TVs.

I must have my devices, like my NAS’s discoverable, because I am constantly moving files back and forth on my networked devices. I have created shortcuts for those devices, but it is much easier to just use Windows explorer, since I have so many different devices."

Their answer…

"check the CoreELEC’s Samba settings…

Items to look for… you can disable them by commenting out the lines, and that should sort out the election process… their defaults are below… smb.conf is usually over in /etc/samba…

The following are default values for the master selection process

local master = yes
preferred master = auto
domain master = auto
os level = 20"

"Insert the following line to ensure that this device doesn’t become the local master browser:


local master = no"

Anyway, the conversation starts here…

I noted this problem as well with my coreelec tv box, also with libreelec. Best is in my testings to switch off samba completely and use filezilla (ftp protocol) or similar to upload or download files to your coreelec box. Unless you really need the samba server very frequently, it is not worth to worry about it.

That is the problem, I use my Windows explorer all the time to transfer files across networked devices.

Yesterday, my Tronsmart Windows 10 microPC was the master. Last night, my devices stopped showing up in my Windows explorer, I ran my lanscanner software, and it could not find my network.

This morning, I disconnected my networked devices and reconnected them ( except my CoreELEC devices, I left them disconnected from my network). After I reconnected my devices (not my CoreELEC devices), my WDMYCLOUD NAS became the network master, which is good, since it is ALWAYS powered on.

I then reconnected all my CoreELEC devices back onto my network. I have given up on configuring CoreELEC to NOT become the network master.

see the attached photos.


If anyone is still having issues, this seems to be the solution:

CoreELEC2:~/.kodi/.smb # cat smb.conf
lock directory = /storage/.kodi/.smb/
name resolve order = bcast host
include = /storage/.kodi/.smb/user.conf <==== this gets included
CoreELEC2:~/.kodi/.smb # cat user.conf <==== create a user.conf with this entry.
local master = no

Coreelec has two network smb parts. It has a client and a server. The client is setup using coreelec system settings add-on. The server is setup using Kodi system settings. Disable the server in Kodi settings and it cannot become master of the samba service but your client should still work.