CoreElec latest 19.4 Matrix dies on N2

Hi, when trying to use my hard kernel box N2 I only get the Hardkernel logo for max 2 seconds and then the tv screen gets black. No more action on the screen. I’m connecting directly to the TV (LG) and not via any amp at this moment.

Logging in over my network on the odroid box I can see it’s working in the sense that I can look for files and so on. I tried one idea of deleting the Textures13.db file, it was recreated much smaller but the symptom is the same, black screen after 2 seconds.

It’s an emmc I’m running but is strange I think if i can reach the box over network if that emmc crashed. Any ideas? Or plan of action?

Textures13.db is just database for Thumnails, don’t see how it can affect booting CE…

If you are skilled enough, you can try with coping “Odroid_N2_boot.ini” to “boot.ini” and “Odroid_N2_dtb.img” to “dtb.img” to root of your eMMC. To get to these files extract “CoreELEC-Amlogic-ng.arm-19.4-Matrix.tar” and go to \CoreELEC-Amlogic-ng.arm-19.4-Matrix\3rdparty\bootloader\ folder, replacing existing files.

Try to see how far will that get you. If result is the same then also copy “KERNEL” and “KERNEL.md5” found in previously extracted tar file in \CoreELEC-Amlogic-ng.arm-19.4-Matrix\target\ folder to root of your eMMC replacing existing files.

If that does not help, I think that only a fresh installation will get you back in business.

Thanks Sholander! I might not be skilled enough but I will certainly try because this makes my life not so good :frowning:
I include a screenshot of my file structure on the N2 box, I’m logged in as a Guest from my Mac. Still able to delete as mentioned before. Im looking for the files you refer to and maybe here is where my knowledge lack too much. I don’t find any of the files/directories you are referring to. Im probably giving bad background info but I appreciate if you can give a bit more feedback. Thanks!
Skärmavbild 2022-04-17 kl. 17.04.03

I also now were able to test the functionality of the kodi installation and if I use the KODI remote app on my iPhone I’m able to choose a movie and start it. It then starts on my TV as normal, so what I don’t see is all the menus in Coreelec. Just as an update.

When CE/Kodi is running on my N2 this is the root file structure I see on my PC:

Folder of interest is flash. Files structure of “flash” folder on my PC is:


Marked are files to be replaced with new ones from unpacked “Amlogic-ng.arm-19.4-Matrix.tar”
Odroid_N2_boot.ini to “boot.ini
Odroid_N2_dtb.img to “dtb.img
KERNEL to "kernel.img

Why you don’t see Kodi UI, I don’t know; somehow your N2 sends a picture format your TV does not recognise…

1 Like

You have the switch at SPI? Try at eMMc. If it works than update Petitboot.

1 Like

You are not alone! I have exactly the same Problem with the same hardware as you since about 1 or 2 days …
Hardkernel Logo showing, but then black screen (display says “mode cannot be displayed”).

Switch is set to eMMC as always (didn’t change anything). Removed the EMMC and put it back in place (“Klick”), but no help! Was there a “silent” update?

Cheers,
Markus

1 Like

No, try to remove resolution.ini from COREELEC partition.

1 Like

Portisch, were to find that file? I have the following structure when looking at my N2 box from my Mac

Skärmavbild 2022-04-17 kl. 17.03.46

I have done some more testing and I believe I can’t see the file because I’m logged in on my N2 machine as a guest (from MacOS). In my Coreelec settings I have a system name of course and a login with password. This is not working to log in with from Macs Finder. I also tried to use the SSH credentials (with is switched on in my Coreelec settings) but that doesn’t work either . Is it another user and PW that is used to connect to the N2 machine?

I also been able to use the system now by moving it to my office, connecting it to my screen. First time I did that I saw that the resolution was reset to minimum for some reason. I changed that to 1080p and restarted (in the office). No problems! All working perfect BUT, moving the unit back to the TV the problem came back. No CoreElec menus. again went back to office, no problem to see all screens…

I have Petirboot dev 20190416

Thattthe cause than, CE make a backup of current used resolution. If you shut down the system, move it to another TV it might get black as the TV doesn’t support it. It also might be happen on some TV’s what have issues with EDID. You can try to dump disp_cap (search forum).

The resolution.ini is on /flash partition. Itt in use read only, so best is to take boot media out to a PC card reader or eMMc adapter and remove the file.

Thanks, my problem is that I don’t see a /flash partition as you can see in my screen dump. No emmc reader available…

Hi Markus, any success? I think this happen when the box auto updated to 19.4 for me. When I was able to see the screen from my computer screen (see above) I had the 19.4 update release on that first screen.
I have a LG TV, you?

Use the search function, mount /flash drive in a ssh session and remove the file. Or buy a eMMc adapter.

So far, no. As a quick “fix” i installed corelec on a spare microsd and booted from that one.
I turned my whole room upside down, but couldnt find this little emmc adapter anymore, so I had to order a new one :frowning:
Just received it and i can access the emmc normally. It looks fine, so i am not sure what to do. Want to avoid a complete re-install of corelec, as i have quite the extensive setup …

In fact, I just found out I made a mistake before (had the switch wrong): When booting from the emmc the hardkernel logo ist shown and the I am dropped into a boot menu from petitboot (text-menu). Sadly my usb-keyboard does not work at this stage, so I cannot select any of the options.

What could be wrong here, why is it not booting into core-elec? Is there a log file maybe I can consult?

First I will try a petit boot recovery:

https://wiki.odroid.com/odroid-n2/os_images/petitboot

UPDATE:
This didn’t help. So I finally reflashed the emmc with coreelec … its working again, but i have to re-setup everything now :frowning:

Thanks for the update, sorry you have to do all this job. I tried a lot of things holding me away from rebooting the full system for the same reason as you. In all testing I suddenly got a feeling about cables… and believe or not, it all ended up in my case (resolved yesterday evening) that one of my high quality HDMI cables gone bad. Never been there before but its never too late to get new versions of problems…