Coreelec Nightly 20200228 won't boot after update [VIM3]

After latest update CE won’t boot with following errors:

Error in mount_flash: mount_common: Could not mount LABEL=CE_MMC
Error in mount_sysroot: mount_common: Could not mount /flash/SYSTEM
Error in mount_storage: mount_common: Could not mount LABEL=CE_STORAGE_MMC
mount: mounting /flash on /sysroot/flash failed: No such file or directory
mount: mounting /storage on /sysroot/storage failed: No such file or directory
Error in prepare_sysroot: final_check: Could not find systemd!

SBC: Khadas VIM3
CE installed to EMMC

I have tried restoring krescue backup from 02 Jan. 2020, and installing clean krescue image from 2019-12-28, both starts as expected, but just after update stops working with same errors.

@SthPhoenix Sorry for late reply.
Looking into this.

1 Like

This is not an issue with CoreELEC.

Khadas seems to have changed the boot labels when installing via Krescue and so when you update your system it doesn’t know how to boot anymore.

Best advice would be to backup your current installation and perform a clean install via the official CE install methods.


Thanks for reply!
Currently I’m using official image burned to SD as a workaround, I’ll try to install it to emmc manually.

Not sure if it works I haven’t tried it yet.
I’ll give it a go when i get a chance.