Coreelec not booting Odroid N2 eMMC [with logs]

I just receive my N2 and 16GB eMMC (with Linux).
I downloaded the image for N2, flashed with Rufus and tried with Etcher too, and Librelec tool. Flashing went fine always. I even copied the Device Tree (tried a fresh install without that) and no go.

N2 boot up fine, I have the Hardkernel logo, then CE is saying resizing partition and reboots. After that, not working. I see the HK logo, than HDMI no input message. I really tried many-many times to flash the eMMC, same. Also, I tried an mSD card, no help - the same.
Leaving it on for some time (few minutes), the HK logo comes back and stays there.

Any ideas how could I debug this or what could I try?

(I tried the SPI switch as well. Set to SPI, it displays the booting, etc, but after just blank screen).

EDIT: after countless number of reinstallations, I switched to HDMI port 2 (with ARC support) on TV and it started working. Don’t ask why and how. I did update SPI to newest version from HK, but on the same HDMI port it didn’t help. Now running fine. I hope it will stay like this.

Can you please let me know the vendor and model of your TV? Some TV vendors gives faulty EDID or HDMI signal range is slightly not aligned.

1 Like

Sure, it is Panasonic 65gx800.
And after working perfrectly fine since yesterday afternoon (after switching to HDMI2 input on TV), now in the morning I switched on the telly and N2 is not working again. The same problem. Restart doesn’t help, Hardkernel logo on boot, and than nothing, blank screen, no CE logo. After a while it returns to HK logo and stays there.

Is there anything I can do? What can be the problem? Maybe setting something in CE config?

Edit: maybe to check somehow the logs? But I can, as the n2 doesn’t boot to CE even if hdmi is disconnected, so no ssh, nothing.

OK, after trying again and numerous power cicles, N2 booted from eMMC.
I turned on debug logging, and here are the logs. log-2020-08-10-10.14.08.zip (113.7 KB)
I hope there is at least something in the logs that might help.

Strange is, tha leaving it off for a while, then turning it back again, it didn start. And again, after several power cycles, it works again. What a hell can this be?

Could be a Hardware issue

  • eMMc faulty -> You can crosscheck using SD
  • N2(memory) faulty

Well, I tried mSD card too, the same. So that somewha rules out the eMMC fault.
Is there a way to test the N2 memory in CE?

Not sure if anything useful is present in the logs?

Set spi switch to eMMC position with SD card CE and NO eMMC installed.

Please look at the lights and see what colors you see when it fails to boot.
If no lights can you tell us what power supply you are using.

OK, I will try again with SD card. I did try it many many times before.
It starts with both red and blue light, but after Hardkernel logo (when CE should start) it just stops and only red light is on. No blue light blinking.

PSU is a Chinese 12V4A psu. Maybe the PSU is the problem? But now at the moment it is working. I did several reboots and fine. If it was a bad PSU than it would not work. Or not?

Big MAYBE.
Both Red and Blue lit is correct behaviour.

No it will do what your’s is doing.
Piss it off and then you’ll have peace of mind.
If you have peripherals plugged into the USB ports it will be worse.

OK, I will receive the new PSU on wednesday and test it with that. Will see if that works. I do hope it is the PSU.
I will certainly report back.

I don’t have anything is USB, just LAN and HDMI.

Is it safe to use it with the PSU I have now, until wednesday?

Just don’t power it off.

Bootup is when the bad PSU usually fail or give issues.

I hope it is the power PSU.

The N2 needs 12V/5A.
So the PSU you have right now is a bit too weak.

12V/5A? The shop is sending me a 12V2A PSU and Odroid uk is selling N" Coreelec edition with 1,5A PSU. My friend ordered from them a year ago, and it is working perfectly fine since then.

Sorry, you are right. It‘s 12V/2A.

1 Like

So I got the new 12v2A PSU, and things look perfect. I will see by end of the week, but it works, boots as it should. Strange thing is that the apparantly faulty psu is also a mid quality one. It was sooo irritating.

Btw, should I update Petitboot to latest (using emmc for CE) or it doesn’t matter at all?

Many thanks for helping me troubleshoot this issue.

You need Petitboot only if you wish to use different operating systems, i.e. CoreElec on eMMC, Android on uSD card and Ubuntu on USB drive. If you use only one than you have no need nor use for Petitboot.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.