Coreelec on mecool km2 plus

Hello all thank you for for the great work u re doing on this os ,
Is it possible to install coreelec on mecool km2 plus android tv 11 s905x4?

I tried it on my Mecool KM2 Plus but no success. There is no reset button that I could find, including in the AV port. Tried using a terminal emulator, but device had to be rooted to use that method, so that did not work.

1 Like

Same , the box seems to be blocked , another problem is i can’t read files from my ntfs hard drive,so i hoped to find a way to install coreelec

You know ip address

Try amlogic tools by Rickey
Think it was version 6

I was able to talk to a95xf4 s905x4 box
With that tool
And reboot recovery command

Maybe will work

1 Like

I doubt if the a95xf4 has a locked bootloader. Most Google Certified device has a secure bootloader, but there are a few exceptions.

You would win that bet!!
Excellent Point

Box was soft bricked/UBT would not recognize
So tried method

It was not Terminal/command

ADB Tool i used

Connect through ip

Just Testing/still woks

Happy Testing

1 Like

Thank you for sharing , can you tell me where i can download the amlogic adb tool plz?

Can’t remember exactly.
Is old utility
Last free version of Ricky …

Good chance it was from Freaktab Archives

Google search also will help maybe

The link in freak tab don’t work no more , i tried using minimal adb tool i get the recovery android screen but i am not sure what option to choose
I tried "adb reboot update " command but the box don’t boot from coreelec
I am using tf card with last ng img nexus
Can u share what steps did u follow to get coreelec working plz

I do not have this box

CoreELEC needs data from Vendor bootload

As clarkss12 has posted bootload is locked on your machine/TV Box

Was posting a methodology to get to mecool recovery.

You could try this way
Is what i was thinking

CoreELEC on TF card insert in box
No idea which device tree to use
Pick one…

Then use ADB to reboot recovery

Happy Testing

1 Like

Using a terminal emulator and reboot update, does not work. There is NO reset button that I can find on this box. Perhaps I need to add busy box to this device.

It’s su single command in Android

I tried the su command, but same thing. What should I type? Thanks

Open the device, look for the UART header and hope you can enter u-boot console. If not it’s not doable without the help from the vendor or with another Android firmware with unlocked bootloader.

1 Like

I was just pointing out to the other poster, that I was NOT able to boot into CE.

1 Like

Thanks for sharing, in developper option i found an option to unlock bootloader but with no success,
Is it because it is a s905x4-b box or it is the same as s905x4
I managed to get recovery mode update from sd card don’t work,
Adb reboot update command reboot the box to Android tv

If you have no reset button
Reset button is broke
Reset button is hidden
Terminal is non responsive
Even if Terminal is responsive

The method i described above with ADB Tool
Will boot/install CoreELEC
From SD//USB

It is the same as holding in reset button
And power cycling box (toothpick method)

However you will get same result as clarkss12
Terminal method.

Unfortunately it is not doable

It is encrypted/locked bootloader

There is an article/thread at XDA Forum
Mecool km2 plus…possible Root
Talks about pins and u-art connect…
As Portisch mentioned

Happy Testing

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.