DAZN addon broken on latest nightly build [AML-S905X-CC]

Hi everybody,
after the last update (nightly_20190813) I found DAZN addon not working anymore.
here’s the log with some testing:


I tried to reinstall DAZN addon, sign out/sign in, reinstall inputstream.adaptive, and reinstall libwidevine via helper, but nothing change.
It was working flawlessly until monday, and nothing else has changed.
Thanks for your work!

Looking the log, I found that he’s searching the inputstream folder in /usr/lib/kodi/addons/inputstream.adaptive but nothing here. I tried a symlink to /storage/.kodi/addons/inputstream.adaptive but the filesystem is ro, so nothing solved.

It’s not only DAZN addon affected, but almost all addons that work via inputstream.adaptive, like HBO-Go EU, Sky Go, TVNow… Netflix being the exception this time :slight_smile:
Have a look about the problem here

Edit: to fix the problem the easiest way is to manually replace old “libwidevinecdm.so” in cdm folder with new version 4.10.1440.18-linux-armv7.so Naturally it needs to be renamed to libwidevinecdm.so and box rebooted…
All WV versions can be found here


Everything works now. Where did you extract the correct library in the new version? I tried to do some workaround but without success.
Thanks a lot!

I did not extract it, but know of the New Zealand site where all WideVine decrypt libraries are stored.
As I read today there will be an upgrade for “script.module.inputstreamhelper” which will then check present “libwidevinecdm.so” and if needed will update it automatically.

Does SkyGo work on Kodi? :scream:

Don’t know for sure cause I don’t have it. A fellow friend mentioned that it stopped working same time as my HBO-Go Eu, and some other “inputstream” video addons, so I guess it does…