Deinterlacer produces a horizontal shaking Picture

Please play this:

On both Boxes, “Nexbox A95X” (S905x) & “T95 max” (S905) the Picture is shaking horizontal for about 1-2 Pixel.
Any chance to get this fixed?

THX for reporting bug. The issue will be fixed in next release. You can try @Computerbastler18 test builds. Don’t forget enable Settings->System->CoreELEC->Disable deinterlacing.

I tested 8.95.0 now.
Display is set to 1080p@50Hz.
When “Amlogic Deinterlacing” is enabled i still have the “shaking video”.
When “Amlogic Deinterlacing” is disabled i have heavy bob deinterlacing flickering.

But now there is 1080i@50Hz Mode available.
When this Mode is used everything looks fine.

But when Display is set to 1080i@50Hz, everything runs in this Mode.
“Adjust display refresh rate” also doesnt work.

Is it possible to force 1080i@50Hz only for this 1 Type of Video and when other Video is played it uses the normal p Modes?

Also with 1080i and disabled amlogic deint i have a problem.
i hit pause and then play and video look normal sharp.
then i hit pause and play again and then video looks unsharp.
something like this:

When 1080i@50Hz is set, my TV does the deinterlacing (flicker fixing), or?
So i think this is a Bug of my Samsung TVs Deinterlacer.
Wrong Field Order?

I dunno. :frowning:

With Display set to 720p@50Hz its also not shaking (Adjust display refresh rate also doesnt work for other Types of Video).
Is it possible to add 1600x900 (or other as big as possible 16:9 resolution) to a Test Version?
Maybe there its also not shaking?

I have an Idea.

Some fake 1080 TV Channels on European Astra have for example 1440x1080 or 1280x1080.
Theese aren’t shaking.
Maybe we can Trick the amlogic Deinterlacer.

If it doesnt eat too much CPU/GPU Power, we can make an optional option which resizes the Video before it it processed by the Video Engine.

1919x1079 for example. :slight_smile:

Maybe this shaking only happens to Video which has exact 1920x1080.

I can live with a slightly lowered Resolution if this shaking disappears.


I recognized that this shaking happens only when there is less Action in the Video.
Maybe adding some slightly Noise can do the Trick.

I hope you understand what i mean.

These were Things i would try to do with ffdshow/Avisynth under Windows.

It would be nice if soebody finds a solution.

raw ts file:

I didn’t find any issue with your sample videos in the latest CE version. My Samsung TV supports also 1080i and in all setting the picture was rock solid. Check you cable and TV set.

With 1080i and amlogic deint disabled. it gets unsharp randomly (hit play pause several times).
With 1080p and amlogic deint enabled i have the shaking.
With 1080p and amlogic deint disabled i have the disturbing bob flickering (headache).

Thats how it is with s905 t95 max and s905x nexbox a95x.

Today i tested the internal android 5.1 of the t95 max with jarvis 16.1 and there is no shaking with 1080p. But of course this is no alternative because nearly every other thing is shit. :slight_smile:

The shaking seems to happen only when video resolution is = display resolution and video is interlaced.

Atm i’ve set display output resolution to 720x576p@50Hz and when video has 720x576i (normal sd channel), the shaking is also there.
Video with 544x576i (european cnn on astra 19,2) doesnt shake.

And now 1920x1080i Video runs at 1920x1080p@50Hz Output.
With “zoom amount 0.99” and “1.01” shaking is gone. :slight_smile:

So its not the Deinterlacer.

Is it possible to make all Video zoomed in by 1 Pixel?
Are the “Zoom amount” Values changeable?
Editing a file, etc?
“Zoom amount” 0.99 or 1.01 use ca 5-8 Pixel.