Disable connman from managing wlan interfaces

This might be RFE, but am looking for a way to disable connman from managing wlan0 (and potentially other interfaces).

Currently these settings are under /etc/connman/main.conf which is read-only.
Would be good to either have:
a) ability to overwrite settings with file in .cache or .config
b) move the file to be located under .config

Connman allows to have some of the interfaces blacklisted, but because on CE the file is in the RO part, there’s no known to me way to disable it and use standard connman option:

# List of blacklisted network interfaces separated by ",".
NetworkInterfaceBlacklist = vmnet,vboxnet,virbr,ifb,docker,veth,zt,ve-,vb-

Motivation in background is that due to limited Connman capabilities need to run proper hostapd in docker and all is great but just need to release this devices from being managed by connman.
A way around could, though untested, be to rename wlan0 interface to one of blacklisted, but again it would be rather a dirty hack due to CE config file layout.

Thanks.

I managed to do something like that by creating a new file somewhere else and bind mounting it.
You can just add it to autostart.sh:

mount /storage/.config/connman/main.conf /etc/connman/main.conf -o bind
systemctl restart connman

About | FAQ | Terms of Service | Privacy Policy | Legal Notice