Disable process aml-vnc

I tried to use commands in CLI:

# pgrep aml-vnc

# kill -9 4368

# pgrep aml-vnc

Why command kill -9 doesn’t kill process completely? process aml-vnc run again with new PID.

It is restarted automatically.

# stop until reboot
systemctl stop service.aml-vnc

# disable
systemctl stop service.aml-vnc
systemctl mask service.aml-vnc

# enable
systemctl unmask service.aml-vnc
systemctl start service.aml-vnc

Thanks for your reply, strange but mask is not working exactly with aml-vnc:

# systemctl stop service.aml-vnc

# systemctl mask service.aml-vnc
Failed to mask unit: File /storage/.config/system.d/service.aml-vnc.service already exists and is a symlink to /storage/.kodi/addons/service.aml-vnc/system.d/service.aml-vnc.service.

# ls -l /storage/.config/system.d/service.aml-vnc.service 
lrwxrwxrwx    1 root     root            70 Nov 26 14:53 /storage/.config/system.d/service.aml-vnc.service -> /storage/.kodi/addons/service.aml-vnc/system.d/service.aml-vnc.service

Sorry, seems the command above applies only to systemd services which are part of the system.

For addons you just need to disable or enable service from addon config.
Or stop them from command line

systemctl stop service.aml-vnc


Thanks for clarification…

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.