Do amlogic-ng builds work well on GXL(S905X/S905D/S905W) devices?

We have a guide:

on GXL inject_bl301 does not show in GUI, you need to ssh into the box and use shell to invoke the command

1 Like

On my S905D device, there is no wake-up problem with the non-ng version. The wake-up issue only happens with the ng version. My problem is: Every time I turn off my TV, CE-ng wakes it up immediately through CEC. So I can never turn off my TV. I can see kodi logs like this:
2020-09-05 12:49:44.012 T:4093665856 NOTICE: OnSleep: Running sleep jobs
2020-09-05 12:49:44.157 T:4093665856 ERROR: Keymapping error: no such action ‘lirc.stop’ defined
2020-09-05 12:49:49.683 T:4093665856 ERROR: Keymapping error: no such action ‘lirc.start’ defined
2020-09-05 12:49:49.765 T:4093665856 NOTICE: OnWake: Running resume jobs

KODI wakes up immediately after sleep and this turns on the TV.
Is inject_bl301 supposed to work in this case?

If not already done, yes as you can adjust the wake up features. You need to run inject_bl301 from console. After a reboot new settings in ce settings/hardware become available.
When this wakeup still happen try first to disable the CEC wakeup option “active route”.

But be sure to use last nightly image for inject_bl301 & GXL!

OK, I will try that.

Try this

Special attention to:

It solved my problem of not booting from mmc

The problem is, the install option 1-4 are no longer offered now. Ceemmc detects CE already being installed to emmc and only offerers overwrite or backup options. I used 3 on my attempt (like I always do) because I don‘t care about Android and always use 3 to have it just as a CE box.

I will try again but I think the emmc of the box is kind of stuck now. I can‘t even install non-ng now. Installtointernal complains about something missing. My guess there were changes make to the bootloader.

I used gxl_p212_2g from the ng build. Also tried the slowemmc version. The Mecool M8s Pro+ will complete ceemmc -x without any kind of error message but won’t boot from it.

No big deal for me as I only reactivated the box because I was curious about the ng build for it.

Anyway, it boots works fine from sd card. So no big deal.

Rebooting from ce menu won‘t help either btw… I had a box in the past where that helped but unfortunately not so much here.

I think it is amazing that there even is a ng build for those old boxes.

A95X S905X (2+8G) installed successfully, no problems.
X96 S905X (1+16G) originally stuck at Coreelec logo. Following upgrade to Android 7 firmware (I used A95X firmware), Coreelec booted normally, no problems.

2 Likes

Everything work fine on my Khades VIM1 (SD and emmc) and on LePotato (SD card) but not on Mini M8S II box (S905X 2+16Gb).

I can boot Mini M8S II from SD (and USB) using new NG build and everything work fine but ceemmc -x fail to install on emmc.

Previous post from @intelmorino make me think about cross-flashing the box and … eventually today I burn the A95X firmware on my Mini M8S II then ceemmc -x succeeded to install to emmc and the NG build boot normally from emmc.
Everything work fine now on my Mini M8S II (after the cross-flash and CE install on emmc).

Working fine on an MXQ pro+ 4k (s905x). I use it with ceemmc without problem.

I’ve been using the latest ng build on my X96 Mini for a couple months now.
All was well until earlier this week when I encountered 2 separate media files that would not play smoothly, in differing ways.
One of the media files was a 1080i film, it was unwatchable, 80% of the frames were getting dropped. I tried another 1080i film and the problem was the same… so there appears to be an issue with 1080i media for some reason.

The other problematic file was not as severe. stuttering audio and occasionally dropping a bunch of frames every 10 seconds.
The codecs were nothing unusual though, blu-ray quality 1080p avc and stereo pcm s16le audio, the same format as 90% of my media files but for some reason this particular file had issues.

I’ll try the latest non-ng build to see if these issues present themselves.

Edit:

1080p VC1 content does not play correctly either. Loads of skipped frames, but they’re not counted by Kodi’s debug overlay.

More details in this thread: No Disable Deinterlacing option on ng builds?

TX95, while NG loads & seems operational, no playback is possible for mp4 with 6 channel AAC

In NG you should use HDMI Milti Ch PCM in audio settings

Absolutely what I am using since ever. I mean it does not play, it means does not play (not just no sound, it hangs on video playback after 5 seconds)

http://ix.io/2EhK

The mecool K1 Pro is reported as working, but does the dvb tuner work with kernel 4.9?

Yes it does.
DVB-T Free to air tested on my device.

1 Like

Thank you. I just use it with dvb-s, does that work too?
Edit and what about oscam+pcsc?

Tanix TX5Pro often crashes when playing torrents online no matter what torrent engine is used.

No commits on github as of July.
Is project still maintained?

GXL devices are already in NG builds. You could use stable or nightly.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice