Do amlogic-ng builds work well on GXL(S905X/S905D/S905W) devices?

[ Support for using an amlogic-ng build on GXL(S905X/S905D/S905W) devices is new and is currently only available in the nightly builds as of the 20200716 build. ]

To help people decide if they want to try using the amlogic-ng(4.9 kernel) build with their GXL(S905X/S905D/S905W) based device instead of the older amlogic(3.14 kernel) builds. I have created a list of devices that according to people that have tested the newer amlogic-ng build on these devices have found that it has worked good enough for daily use in their opinion.

Devices reported as working well with amlogic-ng:


  • Libre Computer LePotato
  • Khadas VIM1
  • Mecool K1 Pro S905D 2gb (DDR4 ram) / 16gb eMMC
  • T95N (M8S II mini)
  • T95m
  • WeChip v5 S905X
  • Abox A1 Plus S905x

If you have a device not on the list above that you have found works well enough that you would consider it ready for daily use then leave a message below with the name of the device, and any relevant information like if something worked better on the amlogic-ng build then it did with the older amlogic builds.

Note: even if a device is listed as working, different versions of the android firmware on the device may give different results.

Note: This thread is meant as an informative list of what users feel currently works well. This is not a support thread. If you need help with or want to report a specific issue please either start a new thread in the appropriate location or post in the nightly thread if the issue is with a nightly build.

4 Likes

x96 s905x 100mb p212_1g.dtb , Does not load, hangs on the Corelec logo.

I confirm the latest NG build works fine on Tanix TX5 Pro(s905x 2/16).
Rebooting takes a bit longer compared to none-ng builds.
The back button on the remote control doesn’t work at all.

Installed ng.generic image to Mecool KM8-S905X box for testing:

Instalation -> No Problem
Restore my daily backup -> NP
Off/On/Reboot -> NP
Playing local/NAS files -> NP
Ethernet -> NP (WiFi? didn’t test)
DRM content Streaming -> NP (have no tuners to test)

That is all I use this box for…

Just to mention, original Mecool remote does not work, but I don’t use it anyway since my WiFi mini keyboard works perfectly.

EDIT: putting remote.conf (from MeCOOL KM9 Pro - same remote as for KM8) to .config folder got the remote to work.

WiFi and Bluetooth ???
Mine does not work.

Using amremote (remote.conf) on mine works.

WiFi 2.4GHz - tested OK at 72Mbits.
WiFi 5GHz - tested OK at 200Mbits
No bluetooth devices to test.

I forgot, how do I get armremote - remote.conf to work?

Copy it to config folder

Reboot

You may have a different WiFi chip from mine.

TANIX TX3 MINI H (S905W) with Mali-450 penta-core

Confirmed to boot from 16 GB Micro SD Card with nightly -ng build from July 16 2020.

All hardware works within manufacturers specifications.
tx 3 mini h S905W

1 Like

It powers Off ??
I ask because we have been trying to fix this Tx3 Mini not powering off / suspend
Box just reboots

1 Like

Thanks for bringing that to my attention. I was unaware of this issue therefore when I finished testing the hardware (WiFi, LAN, Audio, Video, etc,) I powered off and unplugged the unit once the power LED went blank, without waiting to see if it would remain off. I put the unit back on the test bench and unfortunately the reboot problem has not been resolved. Everything else works.

1 Like

NEXBOX A95X-B7N (S905X) with Mail-450MP penta-core GPU

Confirmed to boot from 16 GB Micro SD Card with nightly -ng build from July 17 2020

All hardware functions within manufacturers specifications (A/V, LAN, WiFi, USB, MicroSD, Power on/off).
nexbox a95x b7n S905X

Tanix TX5 Pro - the same problem.

My TX5 Pro does Power OFF and ON.

Problem is i am using an Android 9 ATV Custom Rom eMMC
I’m booting CE via SD Card

You will have to open a new thread under testing and development category for the TX5 Pro
The version of Android Rom may be required.
Unfortunately these are early days of testing GXL Amlogic-NG so issues are going to pop up.

1 Like

Confirming Tanix TX5 Pro (S905X) running CE - ng powers on and off with the factory remote.

1 Like

Thread is for GXL devices.

1 Like

That should read Tanix TX5 Pro (S905X). Corrected.

X96, S905X, 2/16, using P212_2g.dtb (July 16 Nightly)

Installs fine
Wifi & Ethernet work well
No Bluetooth onboard
Reboots & Powers on/off from garbagy original remote using remote.conf
Plays content from NAS
Idle CPU temps seem slightly higher, 59°C vs ~52°C with older kernel.

Only issue is that it throws segmentation faults in SSH (using the July 16th nightly), while decompressing tar.gz backup. Will upgrade to later nightly/try another SD, etc before opening a proper thread.

The temperature difference may be due to the governor being set differently on the amlogic-ng builds then it was on the older builds.

If you go
Settings > CoreELEC > Hardware > Performance > CPU governor
Then you can change the governor to ondemand which well help bring the temps back down towards what they were before.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice