Docker on 19.1 (Matrix)

Is the docker plugin available for 19.1? Just pushed update from 9.2.7 and got message that docker add-on is not compatible and can’t find it in repository for CoreElec.

yeah, the unpackaged (not ready to be installed) source of the docker add-on is here:

But, how to get that packaged is different story, assuming one doesn’t want to play and compile full Coreelec.

Would there be a good soul and point to even rc packages?

Docker is available at addons->services->docker

I’ll answer myself and if it is not the best answer, please correct me.

Found this:

where there is link to:
https://relkai.coreelec.org/addons/19.0/Amlogic-ce/arm/addons.xml.gz

Thanks to vpeter again!

Not sure though if it is the right place for Amogic-ng (Odroid N2) users.

@Vasco - thanks.
Had v9.2.7, updated to 19.1 and got message that Docker plugin is unsupported and there wasn’t any way to update it, checked CoreElec Team repository and it wasn’t there. Maybe a complication of the fact that Kodi tried to refresh repositories, before DNS was available? I’ve local DNS within Docker container - so could be chicken and egg situation, but normally it was finding newer packages - not sure why not this time.

1 Like

Sometimes you have to force update repositories pressing left in menu, it’s alongside view options.

@Vasco, thanks - tried couple of times - unfortunately still the same.
Tested with fresh install and indeed - then Docker is visible.
Noticable is also number of categories and add-ons missing on the updated system within CoreELEC add-ons.

What’s the best way to proceed?



image
As you can see version is still 9.2 - it should be 19.1.xxx.

Select CoreELEC repository and open context menu then select refresh. If it doesn’t help … then I’m out of ideas other than reinstall (clearing kodi settings from CE settings addon).

Thanks @vpeter. I’ve been pulling my hair out and came to conclusion that sometimes full reboot helps :wink: And it did - details below.

Thanks to @Vasco .

Had to fully reboot system (Kodi restart didn’t help) after updating DNS server settings in “Connections->Edit”.
Updating just resolv.conf to proper server, validating that all connectivity works, forcing update or even restarting Kodi didn’t help.
Because DNS server settings where updated each time by Connman at its start time, had to update that and only after full reboot it worked.

Docker is visible now and plugin updated. Other problem is that Netflix plugin for whatever reason claims to be incompatible - but that’s different subject.

Hope if anyone runs into same problem - will get it resolved. This would only happen to people running local DNS under Docker on same system (as it gets into chicken and egg situation) + discovery was that full CoreELEC reboot had to be done to force Repository retrieval.

Netflix uses another repository for Matrix. But with all the piracy garbage you have in your system I’m not surprised you have problems with matrix (or any other version).

Netflix required indeed to add new repository - thanks for help. btw. checking a repo doesn’t mean anything is installed and since none of these temp/test repos were providing any of the problematic or dependant add-ons - themself were irrelevant - in fact added to check if something would help.

You can use this list for future reference:

https://kodi.wiki/view/Official:Forum_rules/Banned_add-ons

As you can read there, it’s not only the addons that are banned, the repos are also. But I’m happy you solved your problems.

Thanks and appreciated all details.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice