Dropped frames issue

I’m having an issue with some x265 files dropping frames. This only seems to happen with files and a MaxCLL over 1000.

samples and logs included. one from the beginning that skips and one 4m 50s in that seems to play no problem.

I have tried with 9.0.3 stable (CoreELEC-Amlogic-ng.arm-9.0.3-Odroid_N2.img) and the latest nightly (CoreELEC-Amlogic-ng.arm-9.2-nightly_20190912-Odroid_N2.img)


@afl1 I can definitely reproduce this.
Do you have any idea why this happens?

I can confirm this issue too. I have lots of such videos :frowning:
they seem to be reported as “skipped frames” rather than “dropped frames”, not exactly sure what the difference is.

I have a couple of movies with this issue, but it starts exactly when end credits begin to roll. If I skip back 10 seconds, playback goes back to normal.
I’m not sure what the deal is with this, but I have a suspicion that the encoders may be doing something funky to conserve file size during credits.

Hmm. But this happens in the beginning (Studio logo, start credits). Your experience is fine at the start funky at the end?

In my case, yes, but it could be different in the files you have.

I remember in old XviD days, some guys does this (different enc. settings) to both start/end credits. But it was decoded just normally.

Not sure if these are normal symptoms or decode issue for specific parameters, as I have just basic x265 encoding experience.

Do they have the same MaxCLL (over 1000) specifications? Assuming you remember what they were.
This issue is oddly specific, as it happens only on x265 with such specifications, and only from a specific “brand” of x265 encoders, other encodes I have with similar MaxCLL play fine…
I hope someone from the team can look into it as there are a lot of such titles.

Edit: I just tried the skipping back or forth a few seconds that TheCoolest suggested and it does seem to make things better. Still be nice if there could be a fix that will not require that.

Color primaries                          : BT.2020
Transfer characteristics                 : PQ
Matrix coefficients                      : BT.2020 non-constant
Mastering display color primaries        : Display P3
Mastering display luminance              : min: 0.0010 cd/m2, max: 1000 cd/m2
Maximum Content Light Level              : 1000 cd/m2
Maximum Frame-Average Light Level        : 358 cd/m2

Media Info says it’s using constant bitrate, but maybe it’s using variable bitrate for those particular parts of the video. Or it could be a new version of the encoder, or something else that is not fully compatible with the currently used decoder fw in CE.
We will be doing some serious overhauling soon, it’s possible that some of the strange issues we have right now will be resolved.

I had a friend who knows more about x265 than me, to take a look at the sample files.
It appears the person who encodes those is using an “experimental” switch called uhd-bd, which attempts to enable Ultra HD Blu-ray format support. One of the sympoms is a very high volume of keyframes:
min-keyint=1 / keyint=24, while default is min-keyint=23 / keyint=250


Sadly, this setting is very common in many x265 videos. I tested a bunch of other files with both MaxCLL 1000+ and these keyframe settings, and they all have this. Others with normal keyframe settings are fine.

I hope this can help figuring out the issue.

The files I looked at have uhd-bd = 0 and min-keyint=23 / keyint=250

What my friend explained is that the keyframes 1/24 (along with some other settings) is an indication of uhd-bd, but if the video is not 3840x2160, it will appear as uhd-bd=0, cause this is a setting for physical discs on which all resolutions are 3840x2160 (black bars added to fill the resolution if needed).
But you have the skip frames issue with default keyframes setting…so hmm. All the problematic ones I tried were consistent with having the keyframes setting and MaxCLL 1000+. While the ones with normal keyframes and same MaxCLL were fine. It seems to always happen in the beginning, mostly after the studio logos. Skipping a bit makes it go away as long as you don’t go back to the very start.
I’d like to test the ones you had the same issue with but had normal keyframes, but I don’t know what they are :slight_smile: