DVD menu blank, cursor is there

Hi. I have a lot of my DVD’s ripped to ISO, and put them on my NAS which is mounted through SMB. Most of them are series, in this example I use That 70’s show Season 2 disc 3. What happens is that the initial trailer / promo runs fine. When that ends it goes to the menu. The screen then stays blank, but the cursor / selector is there. The music plays. If I just enter the dvd starts playing. If I then go back to menu it works fine.
When I restart the DVD and am on the blank menu, when I just let it there, I guess at the point the music restarts everything practically locks up. 100% CPU load on all 4 cores and even SSH takes about a minute for each command to recognise, let alone reproduce it.

I came from LibreElec 9.0.2, where the menu’s work fine but there I have MP2 audio issues, which work fine under CoreElec. I have tried some development builds from LibreElec on kernel 5.x, which also have that DVD menu issue.
It’s similar to https://forum.kodi.tv/showthread.php?tid=335979 and https://forum.libreelec.tv/thread/9105-dvd-title-menus-rarely-appear/, and there are more to be found.

As this is my first post, it seems I cannot upload any files. I’ve put them on a onedrive.

The CoreElec log, so the one that is NOT working properly:

https://1drv.ms/u/s!As_wCUgs-pjPgj4fHldtEbpAKjS4?e=5bw8ca

During the trailer I press UP to skip to the menu. The following line indicates that:

2019-11-01 16:04:25.083 T:4093931536 DEBUG: HandleKey: up (0xf080) pressed, action is ChapterOrBigStepForward

So from there on, the menu should be build up or shown.

For reference, I also have the LibreElec log, which does not have that issue. Not sure if that helps.

https://1drv.ms/u/s!As_wCUgs-pjPgj0X3WlHagskQHK6?e=lAORtz

Same, I pressed up and from here the menu starts:

2019-11-01 15:38:58.093 T:4087463952 DEBUG: HandleKey: up (0xf080) pressed, action is ChapterOrBigStepForward

If there is anything else you’d want me to test or provide just ask. The wife and kids are extremely annoyed by this, which I understand. Would it help to try a physical DVD with an USB dvd drive for example?

Uch, these limitations for new users… I saw I put a wrong link in my startpost for the CoreElec log. However, I can’t change it as it tells me ‘new users can only put 2 links in a post’. I can’t edit the post at all as it keeps giving me that message.

So here’s the correct one:

https://1drv.ms/u/s!As_wCUgs-pjPgj9BSNn1Xfv-5pgS?e=ML5tJ8

I’ve just filed a bugreport for this, as no-one responded here and I think it’s a legit bug.

Unfortunately, there is no response on the bug report either. But it’s still a huge issue for the Odroid C2.

Can other with Odroid C2 confirm that DVD menu’s aren’t working correctly when first starting a DVD ISO?

Should be fixed in tomorrows nightly!
It look like the error was since 2015 on Amlogic devices.
All (Amlogic and Amlogic-NG) where affected.

DVD and BD-J menu getting now hardware decoded!

Excellent find! Did the git log provide any clue as to why that extra condition of “hints.stills”?

Now, i have also blank menu with new build.

What does mean “also”? Was it working before? If yes please upload your used DVD ISO somewhere and send me by PM the link.

It Mean, that i have now a blank menu and submenu.

I cant upload 2x9 GB.
At first, i give you a debug log.
http://ix.io/2eOu

and here is a debug log with nightly from 18.03.2020 with coreect dvd menu

http://ix.io/2eOw

I tested now your samples and both are playing fine here on N2 with Amlogic-NG and H96Pro+ with Amlogic image. Even with and without the last change (remove of ‘stills’ check).
Maybe you need to check your Kodi player hardware acceleration settings?
To make a log please enable video component and enable debug logging.

Here is the debug log http://ix.io/2ePy
If i go to submenu, the screen is blank.
I have also tested it on an w95 Box with actualy nightly, and there is the same error. hardware acceleration is enabled.

More detail, make a short video where I need to enter the menu

EDIT: Have seen it now on DVDMenu2.iso, menu Ton
Looks like it’s because the menu have a framerate of 0

EDIT 2: Yes it’s solved with software decode if fps == 0, will be solved in next nightly.

1 Like

Sorry, I’ve just found lots of messages from this thread in my spam. I’ll try the latest nightly as soon as these times do allow and report. Thanks for the work so far!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice