Emby Docker keeps crashing

Hi,
I am desperatly trying to get Emby Server running on a S912 box.
I am new to employing Docker via commandline, seems to be easier for me to get dockers set up on unraid :smiley:

I read the instructions found here.
But seems I am not succsessful at all.

I tried to delete as many options from the startup command as possible to be sure none of them keeps the emby server crashing.
But even this minimal setup doesn’t work:
docker run -d
–name embyserver
-v /storage/dockers/embyserver/config:/config
-p 8096:8096
emby/embyserver:latest

As mentioned in the linked tutorial, I installed portainer and so I am able to see, that the container is up for like 1 second and shows IP and port but then it is stopped.

Before I also had the option --restart unless-stopped which of course made me think the container was running but just unreachable. Removing that now showed me, that it is crashing.

How do I get logs if the container is up for such a brief time?

Edit:
Yeah, nevermind, I was using the wrong image. On the S912 Box emby/embyserver_arm32v7:latest would be the right one.

I do not know Emby, a year ago I tried Jellyfin which is similar on an x86_64 device and I had no problem although I finally uninstalled it due to CPU consumption.

Look at hub.docker.com for the most outstanding images of Emby, I have seen two, emby/embyserver and linuxserver/emby. Also look for information on github.

If your container crashes this means that something is wrong or incompatible. I think that hardware encoding can not be used on any amlogic processor.

As I edited my post, I figured it out myself, right after posting the issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice