EPG time problem

Hi, I use a Mecool K1 PRO for a long time, always with with current coreelec.
My problem is this:
I do a cold start, the system time is correct, but the EPG time is back an hour.
If I do a warm start now, then the system time is still correct and the EPG time too.
Believe me, I’ve been trying for months, I don’t check it out. Maybe someone can help me on my way.
Thanks.
Alexander

For a test do cold start which has wrong epg time. Then from menu only restart Kodi and check the time again. Is it still wrong or this time is correct also?

Then the EPG time is correct.

Try to enable wait for network in CoreELEC settings. Somewhere under Network.

Yes, it is under options–>Coreelec–>network.
I have already set it and I set the maximum possible waiting time.
Unfortunately, that didn’t solve the problem.

Then try to delay Kodi start with sleep in file /storage.config/autostart.sh with a content inside

sleep 20

Does it help? If not try to use larger value.

Thank you, sleep on 60 solved the problem.

One minute is LONG. But if you don’t reboot often this workaround is still ok :slight_smile:

You should figure out why this happens.

Try to login with ssh as soon as possible after cold boot and try to ping

ping pool.ntp.org

and try to estimate how long it needs.

Ok I will check it, but I’m happy with “60 sec”.
Thanks for your help!

1 Like

I get this problem all the time from the inception of my use of CE and back when LE was the thing to use and have tried dozens of things over time.

I find that it is just inconsistent and it can happen after a cold or warm boot and there is no specific pattern.

But I did find a quick way to sync the time without a reboot and that is to go to the PVR & Live TV section is settings and first clear the channel data.

Then go to the addons in settings and disable and then re-enable the Tvheadend Server 4.2 in the services section.

This forces a quick re-sync which works every time.

Only takes me 30 seconds, so quick to resolve.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice