Error building EmuELEC for s905x3 devices

Hello

I’ve been trying to build EmuELEC for s905x3 using the following commands in ubuntu via virtual machine in virtual box.

sudo apt update && sudo apt upgrade
sudo apt-get install gcc make git unzip wget xz-utils libsdl2-dev libsdl2-mixer-dev libfreeimage-dev libfreetype6-dev libcurl4-openssl-dev rapidjson-dev libasound2-dev libgl1-mesa-dev build-essential libboost-all-dev cmake fonts-droid-fallback libvlc-dev libvlccore-dev vlc-bin texinfo premake4 golang libssl-dev curl patchelf xmlstarlet default-jre xsltproc
git clone https://github.com/kevinrivm/EmuELEC.git EmuELEC
cd EmuELEC
git checkout master
PROJECT=Amlogic-ng ARCH=aarch64 DISTRO=EmuELEC make image

But It always fail to install one or another packages no matter how much RAM or HDD I set.

stdout.save (11.0 KB)

Any ideas?

ARCH=arm

I’ve tried also with that :frowning:
PROJECT=Amlogic-ng ARCH=arm make image

It freezes the machine in the package 82

Do you have enough space and ram? Probably not enough ram.

I’ve tried with 10gb of ram but with the aarch64, I’ll try with arm and let you know what happen, thanks.

Hi,

No luck, I’ve tried to build use


PROJECT=Amlogic ARCH=arm DISTRO=EmuELEC make image  
 

I’ve used 10 gb of ram and 200gb HDD 128mb video memory, in the monitor the ram was never overloaded.

It gave me this error, attached the log


stderr (271 Bytes)
stdout (1.6 KB)

BTW I’ve installed the package libevdev with sudo apt -get install -y libevdev -dev and still no luck

Now it fails with one package. Maybe @shanti could help?

Btw: installing such package as libevdev on host would not help.

Ok, many thanks, I’ve also put the topic in EmuELEC forum, I find this forum, maybe it could help: Gentoo Forums :: View topic - [Solved]Simulating a key press in C with Evdev

Try

PROJECT=Amlogic ARCH=arm DISTRO=EmuELEC ./scripts/build libevdev
PROJECT=Amlogic ARCH=arm DISTRO=EmuELEC make image
1 Like

EmuELEC is no longer ARM so it needs to be ARCH=aarch64, or also add libevdev to the depends in the package.mk:

PKG_DEPENDS_TARGET="toolchain SDL2-git libevdev"

Finally I can compile. I used ARCH=aarch64 with Ubuntu 10gb ram, 6 cores, 200GB HDD and 128 of video memory, thanks @shanti @vpeter

More observations: Problem building EmuELEC image - #5 by kevinrivm - General - EmuELEC

1 Like

No official version starts on X96_Max_Plus_Q2 and stops with a message

Error in mount_storage: mount_commin: Could not mount LABEL=STORAGE
.

CoreELEC saved to a USB stick with Rufus starts up without any problems in X96_Max_Plus_Q2.

=== Aida64 ===
Android Version: 9 (Pie)
API Level: 28
Rooted Device: Yes
Bootloader: U-Boot
Build ID: X96Max_Plus_Q2_20201209-1446
Codename: REL
Fingerprint: Amlogic / franklin / franklin: 9 / PPR1.180610.011 / 20201209: userdebug / test-keys
ID: PPR1.180610.011
Incremental: 20201209

p.s. 1
Root Checker does not confirm the existence of root. Perhaps AIDA64 has a problem reading the root rights correctly.

p.s.2
After upgrading to EmuELEC 4.2 TEST, X96 starts.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice