Error on installing picodrive


#1

Hi guys

playing around with retro player in the new build, the emulator “genesis Plus GX” crashes for me after the sega logo so want to try the other one that is, “picodrive” .

When I select the rom file it pops up writ the error,

Add-on couldn’t be loaded.
an unknown error has occurred.

Any ideas?


#2

@shanti would be the best one to help here.

Please post your error logs.


#3

Genesis Plus GX sometimes crashes on some roms, have you tried another one? or does it do the same on all of them?

Logs would be needed to know why picodrive is failing.


#4

hi @adamg and @shanti

it won’t let me upload logs because im a new user, paste bin won’t let me paste them because they are bigger than 512kb.

I’ve put them one my drop box

Matt


#5

Some interesting things I found by quickly looking at the logs (I am at work ATM)

18:01:23.873 T:4090511376 DEBUG: Select game client dialog: User cancelled game client installation
18:01:23.873 T:4090511376 INFO: RetroPlayer[PLAYER]: No compatible game client selected, aborting playback

It seems Kodi is detecting you cancelling the installation of the core?

I am going to have to install retroplayer from scratch on my box and see if I can recreate this.


#6

Hi,

Thanks for the reply,

interestingly I’ve just removed the pico drive add-on and rebooted.

When I select a game and select pico drive it starts to install then fails with that unknown error, when I try again it says pico drive is installed but won’t launch the rom, just comes up with the same error.

Thanks for looking

Matt


#7

I’ve been trying for a few hours and I get the same problems as you, I think those emulator cores don’t want to play nicely with amlogic :confused: