Ethernet No longer working on MINIX NEO

#1

Strange issue out of pretty much nowhere. I’ve been using CoreELEC on my Minix Neo for quite some time now. For whatever reason, the Wired Ethernet no longer functions. I’ve had to enable WiFi in order to use the device in the interim. I swear I was using it one night (it’s hooked up to the bedroom TV), fell asleep, tried to use it the next night and noticed nothing was connecting. I went into the CoreELEC add-on within Kodi and scrolled down to the connections and there was nothing listed. The device is plugged into a hardware switch and that ethernet plug is indeed light up. I unplugged the Ethernet cable from the device and the corresponding port on the switch went dark.

So, not entirely sure what the steps would be to troubleshoot the issue?

#2

Are you running nightly or stable?

#3

The “about” page says ver 9.0.1

#4

Still can’t get wired ethernet working…

#5

Neo U1 or Neo U9-H? Are you using the right Minix dtb? On Android everything is good?

#6

Everything WAS working fine, had no issues with it for months. Was watching a movie, woke up the next morning, Ethernet is gone. Not sure if an update pushed out on your end that “killed” the Wifi driver or something? That’s the only thing I can think of. Unless the whole Android box just “broke”?

I haven’t booted into Android since I got the device. I’m going to have to research how to do that again.

#7

Have you tried in android as @Blakey said?

#8

Just did it now. Forgot what the steps were to NOT boot into Android since I’ve been using coreELEC for so long. @Blakey, the wired ethernet works fine in Android. Wifi is disabled, I was able to launch Chrome and browse to YouTube.

It’s the NEO U-1

So the issue has to lie with coreELEC?

#9

When you get no connection what does ifconfig say on a SSH connection?

I have seen some strange LAN connection issues on the N2. I just cut the power and shaked the LAN cable a little bit. Then reapplied the power connection. After booting the LAN is working again. I don’t know if this is related to CE or if it is a hardware issue. Also I don’t know if it is a connection or power issue.

Edit: SSH will not work without LAN. I used a UART connection.

#10

Sorry, my knowledge doesn’t go as far as a “UART connection” - never heard of that before.
I’ve tried shaking it, plugging and unplugging from device and switch. Cycling the power, turning on and off WiFi, no avail.
Simply worked for months and then one day just decided not to work anymore.

#11

Try a fresh install on another SD card or USB stick. Can you try the newest release if you want: https://releases.coreelec.org/

#12

There has been no updates since 9.0.1.

Your post is ambiguous as your saying ethernet does not work and then talk about the wifi driver and cycling wifi?

Things don’t just go bad over night so it has to be your hardware has gone bad or a configuration issue somewhere.

#13

@adamg I was replying to @Portisch comment about shaking the LAN cable and cycling the power. I was simply stating that I tried it all… cycling power, unplugging and plugging in the LAN cable, turning on and off the WiFi setting, etc…etc… in an attempt to get the wired ethernet to come back on.

You state things don’t go bad overnight, but then say my hardware has gone bad. That would indeed be something that went bad overnight, wouldn’t it? So I guess your post is now “ambiguous”?

@Portisch, I’m assuming that ifconfig command via SSH would only work when the device is booted into CoreELEC?

#14

My post was clear and concise so I fail to see how it was ambiguous?

Have you tried the suggestion by @Blakey?