Ethernet remains on when N2+ is shut down/suspended

The ethernet port LED’s on my N2+ stay on when the device has been shut down and when it’s in suspend mode. Is this normal behavior? The green LED is solid, and the amber one blinks intermittently.

If this is normal, is there a way to turn off ethernet at shutdown/suspend, or, failing that, to turn off the LED’s?

Running 19.2-Matrix_rc2 and latest petitboot. I have wake on lan set to 0 in config.ini

Yes, normal and it can not be changed. Only way is to unplug the DC power.

I have a small bottle of black nail polish for electronics that live near my TV. :grinning:

Okay, if that’s normal behavior, I’m fine with it. Just wanted to make sure my computer hadn’t become self-aware and hacked itself into the matrix when I wasn’t looking.

Your computer is never really fully off otherwise features like wake on LAN could not work.

I think if you disable WOL and USB power Ethernet will be off. At least it was before.

On the N2+ WoL and USB Power can’t be activated, it’s been like this over many previous builds as well. You can switch them on, back up out of the menu and re-enter and they will be disabled again.

I thought WoL used to work but it doesn’t any longer as it can’t be enabled.

Do you have WoL enabled or disabled in config.ini (wol=1 or wol=0)?

1 Like

I added it and that did the trick, thank you. Where can I learn about other options that go in config.ini as mine was simply blank?

edit

Interestingly after adding the WoL line and rebooting my configuration.ini has several entries:

wol=1
cec_osd_name=‘CoreELEC’
keymap=‘us’
usbpower=‘1’

Don’t know about any other explanations for "config.ini"entries other than those already contained in the file.
I run CE 9.2.7 on my N2 and in my default config.ini I have those settings for WoL.

Btw, I can send you default config.ini which somehow seems to be missing on your instalation.

I confirm when WoL and USB Power settings are off the network is powered down with no lights or activity showing.

CEC wakes up the N2 immediately after turning it off but this is a known issue I believe.

Sure you can list what should be in it, I’m not sure why mine was blank.

Here is the link to default config.ini for N2

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice