External Drive not being mounted on boot

Hi guys,

I’m running CoreELEC on an Odroid C4 and am having trouble with an external hard drive, it doesn’t mount automatically on boot. Nonetheless, it does mount automatically if I connect it after it has already booted, or disconnecting and connecting it again (if it was connected while booting).

The external drive (labeled MEDIA) is formatted in ext4, and I have tried connecting a flash drive as well (exfat), and the flash drive does connect automatically on boot.

Hope someone has been there before and can point me in the right direction.
Thanks in advance!!

dmesg output:
http://ix.io/3lmk

It doesn’t appear on when running usb-devices, until I disconnect it and connect it again

blkid After: (MEDIA is the drive)

If you’re trying to mount a portable drive with no external power supply, then I have a possible explanation for you. There’s not enough power reaching the drive.

Do you hear any clicking sounds from the drive? If you do, try connecting it via a powered USD hub.

It is a portable drive with no external power supply but it is an SSD drive, not as power-hungry as a mechanical drive, do you think that could still be the problem?

It is a mSATA SSD, connected with a USB3 to mSATA adapter.

Sorry, I haven’t the experience to advise on that. All I can offer is something I’m sure you’ll have tried - unplugging all other usb connected devices other than the SSD. There should be ample power to drive the SSD in that scenario.

Thanks anyway.

It normally is the only thing connected, I have just tried with the flash drive as well to test if the flash drive mounts automatically and it does. So I guess it is now a power issue, still trying to find what could be.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice