External SRT sync

Got the N2 just a couple of days ago.
I was watching a tv show today, it has a lot of srt subtitles added to the mkv, but not the one I was looking after, therefore downloaded it through CE.

Around the first few minutes, I skipped back 30 secs and noticed the subtitles lose sync. Tried skipping back and forth to see if that fixes sync but it only seems to increase the offset.
Restarting the video fixes it, although when I restarted it, a random subtitle from the mkv selection was displayed instead of the external one I downloaded and was watching with (not even the first one that’s on the list).

I’m currently running the 09-19 nightly.
I have no idea if this issue is recent or prior. I actually never used the 9.2.0 stable build as the 09-17 nightly was offered for download the second I started the box for the first time, and didn’t use external srts till the 09-19 one.

Another thing I noticed is the watched check mark disappeared on vids I watched before updating, I did do some reboots and disconnected the power supply a few times to setup and test some stuff. The “partially watched” mark doesn’t seem to always stay in there either.

Kinda weird since srt subs are time based. I used a website to upload and adjust the offset.

Think you didn’t understand what I mean. The srts are fine, they just get async if I skip the video forward or back at first few minutes of the video (I tried to do it in the middle of one and it seemed ok). I tried another one with pre-muxed srts and didn’t see an issue there. Shutting down the video and restarting it again gets them back in sync.

I understand, subs lose sync after FF or rewind. Do the subs FPS match the video?

Yes, they are. It’s not really FF or RW, it’s when I use the skip steps. Might be also in normal rewind etc but I didn’t try that.

This is most likely a Kodi problem.
Try to see if this is reproducing in Kodi on Windows or Linux/Android. If it does, report it to the Kodi team.

I’ve been using Kodi on windows for years and this was never an issue. I never moved to Kodi 18 though. Still using 17.6. I made this move pretty much so I can play 4K easily which is a bit of a nightmare on windows.

OK. Installed latest Kodi 18 and it seems like I can recreate the issue there. Testing it again on 17.6 all is well. How very annoying!

You have to report this to Kodi then.

Will do. Thanks.