First subtitle on S905x2 and S905x3

Just something minor I have noticed. I have both S905x2 and S905x3 boxes running CoreELEC. This is just an observation and my guess is that it may have been a bug with S905x2 that was fixed in S905x3 amlogic kernel??

After each power off/on, I notice that the very first subtitle line only will “stutter” or “jump” slightly on the S905x2 box. However, this does not happen on the S905x3 box - subtitle playback is perfect 100%. Both boxes are set up identically and use the same skin, same settings, same video files etc.

Once the first subtitle has been displayed with the stutter, every subtitle afterwards is fine - even for different video files. This will not happen again until the box is powered off/on.

I thought it may have something to do with dirty regions “algorithmdirtyregions” value, but setting this on or off made no difference for the S905x2 box.

I have the same on my GTKing (S922X)
First subtitle always stutter video but only after start movie.
If I stepback for examle 5-10 seconds without stop playback this subtitle playback correctly.
mkv srt
now 19.3 but it was on all previously releases

Been doing some testing. I have found (for S905x2 box) that using “VobSub” subtitle format does not appear to have the stutter issue for the very first subtitle line per session. There’s a free program called “Subtitle Edit” that is a wonder for editing and converting subtitles and this program can batch convert all your subtitles very quickly. I tried using “SubRip” (.srt), “VobSub” (.sub/.idx) and “Advanced Sub Station Alpha” (.ass). Only the “VobSub” format did not stutter for the very first subtitle. This is an OCR based subtitle, so the files generated are more like image files than just text. The only downside of “VobSub” is that the subtitle files can be up to 7Mb or so, for each movie, so they can take a lot of space if you have lots of video files (like I do). The size depends on the number of subtitle lines.

Not sure if it’s worth the extra space for the sake of one subtitle line stutter.

Actually, I may have been presumptious regarding S905x3. There is the same issue as with S905x2 - very first subtitle will stutter and then there is no more stuttering until next power off/on.
The first subtitle doesn’t appear to stutter if the scene is a very still scene, but if the scene has some horizontal or vertical movement, the stutter is exaggerated. Again, this is only the first subtitle only per session. However, it does appear to be the same issue on S905x2 and S905x3. If your first subtitle is displayed on a static scene, you may not notice it and then everything is fine from that point onwards.

Also, just FYI, if hardware acceleration is switched off, there is no subtitle stutter at all. This does strongly suggest the issue is with the amlogic kernel. This also raises the temperature of the CPU.

I just upgraded to latest nightly of CoreELEC 20 and the first subtitle stutter does not exist on S905x2.

Maybe it was a Kodi issue after all?

Anyhow - good news methinks.

Ok - I wish I hadn’t gone down this rabbit hole…

The key to this may be the “CPU governor” setting in CE. By default it is set to “performance” under CoreELEC settings/Hardware. My “autostart.sh” sets this to “ondemand” - has done this for years.

If I set it to “performance” it appears the issue is resolved. I have tried a few times now with the same subtitle on the same movie that used to stutter, (when using “ondemand”), and after each reboot the first subtitle stutter is now gone on both S905x2 and S905x3.

This would explain why my fresh install of Kodi 20 worked as this had “CPU governor” set to “performance” by default.

That’s it for now. Hope this helps somebody else.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice