[FIXED] Unexpected [standby_pc_on_tv_standby] setting value


#1

Since 9.0.1 (jumped from 8.99.2) I can see occasionally
ERROR: OnTvStandby - Unexpected [standby_pc_on_tv_standby] setting value
error messages. I dont use any CEC related settings (everything off or ignored), using CEC just for control CE.

<settings>
    <setting id="activate_source" value="0" />
    <setting id="button_release_delay_ms" value="0" />
    <setting id="button_repeat_rate_ms" value="0" />
    <setting id="cec_hdmi_port" value="1" />
    <setting id="cec_standby_screensaver" value="0" />
    <setting id="cec_wake_screensaver" value="0" />
    <setting id="connected_device" value="36037" />
    <setting id="device_name" value="Kodi" />
    <setting id="device_type" value="1" />
    <setting id="double_tap_timeout_ms" value="300" />
    <setting id="enabled" value="1" />
    <setting id="pause_or_stop_playback_on_deactivate" value="231" />
    <setting id="pause_playback_on_deactivate" value="0" />
    <setting id="physical_address" value="0" />
    <setting id="power_avr_on_as" value="0" />
    <setting id="send_inactive_source" value="0" />
    <setting id="standby_devices" value="231" />
    <setting id="standby_devices_advanced" value="" />
    <setting id="standby_pc_on_tv_standby" value="36028" />
    <setting id="standby_tv_on_pc_standby" value="0" />
    <setting id="tv_vendor" value="0" />
    <setting id="use_tv_menu_language" value="0" />
    <setting id="wake_devices" value="231" />
    <setting id="wake_devices_advanced" value="" />
</settings>

Anyone experience this? Its from CEC, and it shows on LG, Phillips. I think its triggered by turning TV off (when CE is running 24/7).

I believe, thats because Ignore - 36028 is somehow missing on PeripheralCecAdapter.cpp’s
void CPeripheralCecAdapter::OnTvStandby(void)

peripherals.xml


#2

Should be OK in future.