Flash stock ROM on X96 Max Plus 2

I bought a X96 Max Plus 2 with 4GB and 32GB. I wanted to install in internal memory so I tried it with “ceemmc -x”. During installation I got an error. When I now try to boot from internal the box doesn’t show anything on the screen and it doesn’t boot. But happily the box does still boot from microSD into CoreElec.

I now wanted to install again stock ROM. But so far I didn’t found a IMG file for my box. I only found a ZIP file for my box. Furthermore I’m sure that Android was showing my box as X96 Max Plus 2T. I only found a ZIP for X96 Max Plus 2. Is it important?

I have a Windows 10 pc. I installed USB Amlogic burning tool. And I tried to install the USB AMlogic driver. But when I connect my TV Box to my pc (only USB cable from TV box to USB port from my pc / didn’t connect TV box with power supply) the USB Amlogic burning tool doesn’t show my TV box.

maybe https://androidtvbox.eu/?s=x96max+plus+2
X96 Max Plus2

Ok. There is an IMG file for my tv box. Thank you.
Very slow download but I’m trying to download right now.

Do I have to connect my TV box with my pc without using the power supply of the tv box? I’m asking because my pc doesn’t seem to find my TV box when coonected to USB.

You don’t need the power supply. The box will be powered by the usb port from the pc. Remember to press the button inside the avport before connecting the box to the pc.

Android 9 is on my TV box again now. So far so good.

But now I can’t boot anymore CoreElec from my microSD card. I didn’t change something on my microSD card. I insert the SD card but the box starts android 9! Do I have to flash the SD card again?

Hold in reset button
Like it is new instalation again

Coreelec should boot

Happy Testing

Yes. Coreelec is booting now. Thanks.

1 Like

I now installed CoreElec in internal memory in dual boot mode. Even that is working. Great.