Flashing Original Firmware after Installing CE to Internal

Just a quick question regarding reverting my box to Android after installing CE to internal. I’ve come to the conclusion that the judders with playback using CE were due to the resolution of the box being 720p even though it seemed to fake 1080p. I’ve gone back to my MXQ’s and the image is fine with hardly any noticeable judder.

So can I flash Android firmware to my box or will it brick it? I actually don’t have the original I have an update so perhaps that won’t work? For the record it’s a Beelink Mini Mx.

My other box I was experimenting with, the Nexbox A95X, is dead! So as said back to my MXQ’s and wondering why I bothered? Oh yes 10bit! Is it worth it? Nooooooo! MXQ’s with K’s build are still very good for up to 1080p so…

As a last word: I’m sure CE runs great for many people but my boxes, the two I was experimenting with, must have had crap firmware because the video playback was grainy and juddery and was not 1080p! Perhaps it was the install to internal that messed up the playback?

I changed the location of your post because there’s a lot of different information in it. Just a slight correction to what you’ve said, the feedback for CoreELEC usage shows us that it runs well for almost everyone and we have a high success case in helping those who have the misfortune of having some kind of problem. We can’t always succeed but I can assure we try. In your case I have to say I got lost in the multitude of posts about devices, problems and all. I hope you can persevere and find a solution that works for you. If I can give you an advice, keep it simple and don’t overthink stuff. Good luck.

Edit: and answering your question, you can reflash android on it if you have the original firmware or other that you like. In freaktab there’s always a lot of help. And for the future, only install CE to emmc after you’re sure that everything works as it’s supposed to.


Well I thought it was fine but either I didn’t notice the drop in resolution to begin with or moving CE to internal caused something to change. I did think it was fine on internal but as I noticed the glitches more and more it slowly dawned on me that the resolution might be the problem. CE / Kodi said the display was at 1080p 60Hz (refresh switching was working) but when I plugged in an old MXQ I could see the difference i.e. The MXQ looked really sharp with noticeably less glitching.

I think the slight judders are there on the MXQ’s but they are much less noticeable and I figure this has something to do with the resolution of the box which in turn may having something to do with the bootloader. Not techie so I don’t know what happened but both the Nexbox and the Beelink had this problem. If I can get the Beelink back to Android then I could run CE from SD and see if it was the move to internal that changed something.

you can make a bootable micro sd card and boot your box with that. It can contain the install version of the android for your box. Something like boot image maker or writer. Then all you need is an image rom file for your box, push the reset pin and start flashing.


1 Like

I can’t remember off the top of my hat whether the non NG versions of CE have the option but can you confirm whether Disable GUI scaling is on or off (system, settings, CoreELEC) as having it switched on can, from my experience cause violent screen tearing and occasional skips etc

Another aspect of quality of video, although related visual clarity rather then issues such as judder that I have recently discovered is that the kind of skin that you use can have a surprising effect on the final output, so just to cover all the bases, make sure that you try the default Estuary skin if you have reverted to another.

It may also be useful (if you have not done so already) to provide a sample of a video that does suffer this judder just to rule anything of that nature out. You can use the excellent avidemix to take a sample clip from an existing video to make quick uploading and testing easier.

1 Like

Ironically I have tried the SD card bootloader trick and got the Nexbox A95X running again so going to try and install an Android rom. Fingers crossed!

Will try with the Beelink later as I need to jump in the bath!!!

Thanks for you help will keep you informed.

EDIT: Took a while but found the stock firmware for my NEXBOX A95X B7N 2GB/16GB, hopefully, will let you know how I get on.
Firmware: https://mega.nz/folder/41AlnCwA#2l7BnhyM5bacFT4DVCNTaA

Mark is that the correct rom for the Beelink Mini MX? Just checking as when I’ve sorted the Nexbox I’ll reset the Beelink.

OK I won’t yap on but to bring you up to date with the NEXBOX:
First firmware, no wifi or remote so flashed the second version on the download (see above).
Second firmware wifi but no remote!
Installed CE on SD card and dropped remote.conf for the box at the top of the card and remote worked fine, I could even turn the box on and off.

Then, installed CE to internal and…
…no remote! Tried dropping remote.conf in userdata and then config, no joy. Put rcmaps and the accompanying file in keymaps folder and…
…still no remote.

So anyway can boot from SD and use the remote but would be nice to get the remote working with internal if possible.

I still think the judder is there so maybe these boxes are just crap! Will play with it a bit and decide if it’s a go-er or a no-er!!! I figure some boxes regardless of their specs just can’t do the job. I mean minimal micro judders every 10 mins is hardly noticeable but every minute or two is not on and they seem more harsh on this box and on the Beelink Mini MX.

Yes still judder and I suspect it might be something to do with HDR. The box has the capability of HDR, I noticed it in the Android settings, but I set them to off in Android. I’m wondering if CE is turning HDR on and:

  1. Increasing how noticeable any judder is to the eye.
  2. Causing a degree of ghosting which is sometimes very noticeable. The ghosting could just be an effect of the HDR highlighting frame blur or whatever the technical term is.

Remote sorted and working with internal install. And the judder I saw earlier may have been due to a CE update downloading in the background, perhaps? So will do some testing. I think it was a slightly different version of Android so it may make a difference to certain boot settings and imrove video playback? Fingers crossed!

You have spoken about judder with 10 bit HDR but hat about more vanilla 4K or 1080p/720p playback?

1 Like

I don’t do 4K as most of my content is 720p 1080p 23.976 fps although I do have some 60Hz and 50Hz stuff. To be honest it’s not even the judder that’s the main issue anymore it’s just the fuzzy crappy picture. I couldn’t believe it when I went back to my MXQ’s it was like going from SD to HD, I jest not! So it’s either the boxes, the Beelink Mini MX and the NEXBOX A95X, or CE. I’m not saying it’s CE but you would think the more advanced S905/X CPU’s would perform better.

I don’t know what’s going on and I’m somewhat resolved to carrying on using my MXQ’s and waiting another year or two before jumping to 10bit capable boxes. If others are lucky and their boxes run really well great but I can’t spend weeks on this. Yes I could buy modern boxes, err, I did! The Magicsee N5 MAX was me going the extra mile and…
… the video was all over the shop, really bad! I would have persevered if the video playback had been good and got the WIFI working etc but without decent playback what’s the point?

Sorry if I seem negative put I’m pixxed off! The install and everything else with CE is great but for me the video playback is what it’s all about and it’s not as good as my donkey MXQ’s. If people just said yes that box and that box are crap then fair enough.

I would still like to see a sample of one of your videos.

10 bit HDR, at least from my experience seems more prevalent with 4K than anything else.

and out of curiosity, have ou tried the same HDMI cable that you use with your MXQ, plugged into the same port on your TV/monitor with the other boxes?

Patrick, it maybe the gpu chip. It’s a mali450 riched with hevc support. It isn’t a fast gpu and rather old. Are you sure the video’s are of good quality, cause they’re 720p? Could try to go for higher resolution video’s and see if the hevc decoding gpu boosts anything.

1 Like

I don’t think it’s the GPU as it’s the same one as in the MXQ’s and anyway the main CPU does most of the image processing. I’m beginning to suspect that it’s the thermal solution on these older boxes. I might try re-gluing the CPU heatsink and maybe running it from start out without the bottom of the unit on.

Again I suspect that many older boxes, but also newer ones, have issues with temps. Older boxes were often designed to run at 720p but had the firmware updated because of the Kodi and HD craze. Older boxes are pushed to their limits and will probably overheat playing HD video and certainly playing 4K. Playing 4K is one thing put playing it consistently without glitches is another.

I don’t do 4K so I’m miffed that these older boxes struggle with 1080p or even 720p. As I keep saying my old MXQ’s (S805) running Jarvis are pretty good and even better with a heat sink added. So I’ll experiment, if I get time, and see if adding cooling helps minimise or even eliminate the stutters.

It may be that older boxes should be put on a different list with a note saying that playback may suffer due to the specifications of such boxes.

EDIT: For now I’m just going to run the NEXBOX A95 upside down due to it’s design as this will help heat dissipation through it’s vent which are on the bottom. If that doesn’t work then I’ll get more drastic. As for the Beelink Mini MX I’ll have to open that up and have a look at the cooling solution as it doesn’t have any vents.

maybe setting resolution to below 720p to test.

1 Like

If I set system resolution to 720p auto refresh rate no longer works on 720p files so the judder is even worse, in fact it’s all the time. 1080p files switch to the correct refresh rate but the ropey image and occasional judder is still there. I figure it’s just older boxes that are the issue and possibly not really compatible with CE.

Might have another go at running some of K’s old builds from SD:

To answer the original question. You can revert back to stock Android. If that works or not is out of scope here. Sorry you had bad experience with CE but installtointernal was never supported officially and there is even a warning. Also we have a lot of heated discussions around where people demanded the installtointernal back into build. Well let this Thread a warning to people then.

1 Like