Frequent crashes & hard lockups with new Odroid C4

I’m trying to get my new Odroid C4 to work as a media player and am having serious difficulties. It’s a replacement for an old RPi 2 that’s been running LibreELEC. I would like some input - e.g. am I having a hardware issue?

The problem is frequent hard lockups and freezes. Often during high load (starting to play a H265/VP9 video) but sometimes also just browsing the Kodi menus. Opening the Media/Player/System info overlay while playing a H265 video seems to be a pretty reliable way to cause a crash. I had a particularly nasty crash (random colored noise on screen + sudden loud white noise audio) entering a path to a network share though so it’s very random. Scared the crap out of me. :slight_smile:

Running ‘journalctl -f’ over ssh during these crashes does not return any info at all. Nothing is written to the systemd log.

I first suspected a power issue, so I switched from my 12V/18W wall-wart to a high quality lab power supply (TTi EX355R). I also put some tension on the barrel DC connector using a rubber band. None of this prevents the crashes.

Weirdly, there is some difference between different OS releases. My first try was running stable CoreELEC (CoreELEC-Amlogic-ng.arm-20.2-Nexus-Odroid_C4.img.gz). I next tried the current LibreELEC (LibreELEC-AMLGX.arm-11.0.3-odroid-c4.img.gz) and this actually seemed to run stable - on the other hand, it doesn’t seem to support H.265 HW decoding at all so I haven’t been able to really stress it. (And this lack of decoding makes it a no-starter for me.)

Then I tried CoreELEC-Amlogic-ng.arm-21.0-Omega_nightly_20230716-Odroid_C4.img.gz and this is noticeable more stable than the stable CoreELEC, but I still got a crash while playing a 1440p H.265 file and opening the Media/Player/System overlay.

Finally, I also tried a different µSD card (all of the above was using the same µSD card) but the new card didn’t make a difference.

So… any ideas?

I found the ramoops instructions and managed to get a log:

This is running CoreELEC-Amlogic-ng.arm-21.0-Omega_nightly_20230716-Odroid_C4.img.gz and the crash was triggered playing a 1440p VP9 video and opening the Media/Player/System overlay. (And then waiting for a reboot.)

“Internal error: undefined instruction”. Huh.

Use CE-20 as Omega is unstable.
VP9 is kind of buggy and not common used format. So I don’t think it will be fixed in future.

Thank you for replying, Portisch! Although, given that these crashes are even more frequent with stable CoreELEC, and happens even in the menus, I don’t think we can blame VP9 specifically? :slight_smile: (There could be multiple issues of course, all resulting in these hard crashes, but…)

It’s interesting to hear that VP9 support is not mature though. That, in combination with the old 4.9 kernel used, makes me think that perhaps I should return this board for a refund regardless and try to find something better supported. I assume then that HardKernel/Amlogic are not pushing support into the mainline kernel?

There is no Amlogic mainline support. Only vendor provided kernel will support all decoder in hardware.

The market for VP9 is just to small so I don’t think the driver will be fixed someday. You only can hope new 5.15 kernel what do support SM1 SoC as well will solve the issue.

4.9 is EOL.

I’ve only ever run off emmc and its generally been rock stable, some of the latest nightlies are not there yet but just run 19 or something until things are fixed. Try an emmc as it takes one, get a usb adapter for it for the sake of a few quid. Im not saying this will fix everything but the c4 is a very solid box.

Thanks for your input Mark22! I tried CoreELEC-Amlogic-ng.arm-19.5-Matrix-Odroid_C4.img.gz and it crashed immediately upon trying to play a 1080p H.265 movie. Ramoops log here:

(Symptoms: frozen screen & very annoying high-pitched beeping sound from speakers until automatic reboot.)

So I guess that does it then: this board is borked. I’ll try to send it back for a refund.

I should add that all these test were done with completely fresh installs; the only settings I changed were to turn off samba and turn on ssh. Everything else 100 % default.

Make a small reproducible sample so others can test it also.

Okay, well, I went to Demolandia and the first video I tried (selected because it’s somewhat small-ish) seems to crash reliably, either directly upon opening the file (twice) or after a few seconds of play (once): Demolandia lg-uhd-LG-Greece-and-Norway-( 4K H.264

Edit: Using CoreELEC-Amlogic-ng.arm-19.5-Matrix-Odroid_C4.img.gz

The issue isn’t reliably reproducible though, it happens randomly. But it isn’t difficult to trigger: any high-res H.264 or 1080p or above H.265 or VP9 file seems to cause a crash quite quickly (within 10s of seconds), especially if I open the Media/Player/System overlay. Anything that stresses the HW, I guess. This is why I suspected the PSU at first.

Edit 2: I should add that a few times I’ve been able to play several minutes of e.g. a 1080p H.265 without a crash. And a few times it’s crashed in the Kodi menus without even playing a video. So, again, it’s not reliably repeatable.

This indeed sound like a broken board.
Either the onboard 5V buck PSU is unstable, or (and more likely) this is a thermal defect, either by bad solder contact on SOC balls, or internal SOC failure.
I suggest to refund / RMA.

Thank you, rho-bot. Something like that is my conclusion also.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.