Fresh Install 8.90.4 - No Remote Files

I decided to do a fresh install of 8.90.4 on my Mecool M8S Pro+ and ran into a problem. The remote control was dead with no functioning buttons. I couldn’t find the required files in the remote repository so I decided to try to create a new one. So I followed my remote for dummies guide, followed steps to opening the IR keytable and then tried scanning for codes. No matter what button I pushed no codes were produced in Putty. I tried new batteries, rebooting, reinstalling 8.90.4 and nothing worked. This Mecool box remote is supposed to be pre-added to Coreelec, but somehow it wasn’t added to my box when I did the fresh install.
I had my Logitech 650 remote working perfectly with this box as well and now there is no response when I use it with the box.
I have a wifi type remote which works fine.
Is there a step I have missed, or a fix I can do to get the remote working>

There are a couple of M8 files in the repo, try them

1 Like

Your using the wrong DTB if you get no output when pressing buttons.

But your right the remote for that box is preconfigured, stop using the kszaq DTBs.

1 Like

I see the M8S folders, but that remote looks a lot different than the remote I have. I still have the remote.conf for the Mecool and opened it and the M8S in Notepad++. They look different ie: Mecool power key =0x59 and M8S = 0x804d. The Mecool looks more like the A95X/Abox A1 Max, but the Mecool remote does not operate the Abox.
Pretty sure I used the right dtb - Mecool M8S Pro+ 2G/16G S905X gxl_p212_2g
So I wrote a keytable based on a wrxtasy remote.conf for this device and tried to activate it in Putty and got these errors:
opening IR keytable:
Activating the keytable:

emphasized text
So I am at a bit of a loss. Next step reload an earlier Corelec version? Or is there something else I can try?

Why don’t you just try one of the folders in the repo, you have nothing to lose. Just copy the files to these locations, then reboot. You don’t need to stop start kodi, all that malarky has been done



I did try those remote files. I get the no device found error I attached to my note. It will not update the keytable. Instead of this running (example):
I get this:

Read my previous post!!!


Can’t say it any more clearer.

Sorry Adam, I missed your first post somehow and that would have saved me a lot of time. Looks like I messed up and used the wrong DTB. I didn’t use a kszaq dtb, I used one from the folder on the extracted Coreelec image. I knew which one the right one was, but I guess I had a seniors moment.
Thanks for your help and sorry for the mix up.

DTB’s are included with our all images, you should only use the ones we provide and no others, expect problems if you do.