Get desperate with several Spotify Addons :-)

Hi together,

I enjoy the work very much of all the kodi, coreelec, Addon-Developers. Thanks for your work.
Anyway:

  • Odroid N2
  • latest CoreElec
  • Audio Connected with the 3,5mm analog Stereo cable or for testing sometimes with HDMI (both connections work with DLNA Music without any reconfiguration of the audio setup (default device, 2.0, no bitstream))

I tried:
“Librespot”: Older Versions, unluckily I dont know which one worked 1 year ago, but it oplays only very buggy (this very old version). Now the newer releases dont get recognized as Spotify Connect Clients by several mobiles I tested it with. In the working old Librespot Version I had to configure the audio device, in the newer ones not, but anyway, finding it as connect client is the problem. Should I perhaps change the port?! Tried it, didnt work.
“Spotifyd”: only works occassionally, mostly good with HDMI connections. Didnt configure it, just used it as connect server. My mobile finds it, as soon as I switch to the connect Client (spotifyd@ondroidn2 or how it is called), I can hear 0,5sec of music, then “pop”, then nothing
“Spotify” (from marcel I think): Works with login on Player, but I cant use it as Connect Client, my mobile doesn’t find it.

What now?

Has anyone the same problems?

I have many Spotify Clients at home (Pioneer amp, Samsung TV, Fire TV Stick,…) they all work with my mobile (Oneplus 6), but the Kodi Addons.

Thanks and regards,
Michael

Hi are you using the box for anything but audio playback? Volumio could be the answer for you because of its Spotify integration. However this is just audio playback software. If your wanting Kodi there is not really anything I can suggest.

Have you tried the unofficial Kodi plugin?

Hi thanks. “Unluckily” I use it for Video (from Server/Netflix/Zattoo) too. Perhaps some kind of dualboot would do it, Volumino and CoreElec.
I will do a test installation of Volumino an a second SD card.

at home I have some addition hardware laying around:
Raspberry 3: bad audio without additional hardware
Rock64: dont know how good audio is

I found that release: https://oph.mdrjr.net/gkkpch/
do you know another one for N2? Thanks

Hi, yes thats nb. 3 one of my 3 tryouts. It runs by using it on the OSD perfectly, but it doesnt get recognized by my android mobile as connect player. If I can get it regognized, I can use it.

Latest versions can be downloaded from:

There are plenty of videos showing you how to setup and configure.

Try this:

  1. Give your box a fixed IP address.
  2. Go to Spotify settings and ensure username and password are correct
  3. Ensure "enable this device as Spotify connect target (experimental) " is on
  4. Ensure “Use Kodi OSD for playback on (remote) Spotify connect device” is on
  5. Once done open the add-on. You should be logged in
  6. Select playback device, and set it to the device you want the music to play on

This works on my network between a TaNiX TX5 Deluxe Edition and an Amazon Echo Dot third gen.

  1. Gets from Router always the same IP, if I remember correctly I gave the DHCP a fixed IP for the player
  2. Is correct, I can login and use it on the OSD of my Adroid N2
  3. done
  4. Tried with and without
  5. Addon logs in, as said on POst 1 I can use it and play spotify with the N2/OSD itselfe, but unluckily cant controll it with my mobile
  6. Tried several settings there. You can choose between “local”, other Devices (my mobile which doesnt find the N2 gets found by the N2 btw.) and the Odroid N2 again by its Name

It doesnt work for me with 2 different mobiles, but I will try another one

Thanks! Regards

Then I am out of options. All I can say is, it works this way on my LAN between a TaNiX TX5 Deluxe Edition running CE 9.2.4.2 and an Amazon Echo Dot 3rd Gen.

Sorry I can’t be of more assistance.

Thanks anyway :slight_smile:

Thanks, have it running. Volume control didnt work. Played around with several Hardware and Software Mixer settings…now I dont have any sound any more :slight_smile:

It’s always something isn’t it?

seams that way. Volumio is wonderfull, but as I googled they have problems with the volume control.
That sucks because the odroid N2 has very good DACs.

So:

  1. Coreelec with Marcels Spotify: works on OSD, but no mobile can find it as spotify connect client
  2. Coreelec with Spotifyd: gets found by mobile as spotify connect client but sound pops after 0,5s of playback via analog audio, while it has no errors with HDMI audio out in a short check
  3. Volumio: Works on browser control and as spotify connect client for my mobiles, but has not Volume controll which I definitly need
  4. Librespot: only old versions worked as Spotify connect clients with volume control but that is over now, it takes several tries to get it going. Newer Versions dont get found by mobiles

I wonder why all the CoreElec Versions have problems with Connections but can do Volume control and why Volumio connections work perfectly but doenst have Volume control. They should work together and combine the working things :slight_smile:

Why ?
You have a very special case.
I have volumio running on raspberry pi - works perfect

After several times of installing “Spotifyd” works now, dont know why…but I am fine with it.

@Tim: because I have a Odroid N2 and there volumio has volume control problems, as I found out through myselfe and google.

Interesting. Don’t you love it when stuff just starts working and you have no idea why or how.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice