Gigabit link defaults to 100Mbit

Not sure how I can fix this, but my N2 seems to always negotiate at 100Mbit rather than a gig, even though it’s plugged into a gigabit switch.

If I disconnect the cable and reattach and run “ethtool eth0 | grep -i speed” it then confirms 1000Mbit, ie. a gig.

Anyone know why this might be?

I have no issues with other devices on my network all negotiating a gig connection successfully.

Oh, I can also run:

ethtool -s eth0 speed 1000 duplex full autoneg off

And that solves the issue but only temporarily, ie. a reboot loses it. Does anyone know how I can make that permanent?

I would first try changing to a known good Cat5e/Cat6 cable, just in case the present cable is breaking down in use.

Have already tried changing the cable and the port on the wall and the socket on the switch at other end!

For now I have added an autostart.sh bash script and that solves the issue.

Can you precise what you put in that file and where it must be placed plz? I would like to make some test on my side because I have network speed trouble too.

Sounds like a bad termination of one of your plugs.

@adamg I tried multiple cables (different brands) different sockets on the wall and different socket on the switch at the other end!

@saroujs You can put it in /storage/.config/autostart.sh

I just used the ethtool tool to force gigabit and full duplex etc. A quick google search will give you the answer.

Did You try the direct connect without the wall socket ?

That would involve taking my odroid n2 into my loft! So no, I didn’t try that.

Maybe the wall socket causing the issue.

That’s also what I am thinking.

I have some background in networking and 99% of the time it is poor termination at the sockets that causes this, have you tried an ethernet tester to make sure a signal is coming down all 4 pairs?

And I have a cable tester that confirms all pairs are terminated.

Also, if I force it to connect at a gigabit I see no issues playing anything back.

I’m out of ideas then other than it being a switch issue.

There is nothing that we can change in the OS as gigabit already works otherwise we would of heard more about this from our 2000+ N2 users.

It is a negotiation issue with the switch most likely (obviously). I had to replace my managed switch probably 3-4 months ago and went for a cheaper non-managed version as I don’t do vlans etc. so maybe it’s just not a very good switch!

Like I said, I see no issues forcing it to a gig so I suspect my cabling is fine.