GT1 Ultimate with Samsung Smart Remote (Q70R)

CoreELEC : Stable release, 9.2.1.
ATV : GT1 Ultimate 3GB
TV : Samsung Q70R
Soundbar : Samsung HW-Q90R
HDMI connection from GT1 => HW-Q90R => Q70R

HDMI CEC remote working out of the box, except the power button.
When shutting down, the GT1 shall be in suspend mode (TV and soundbar shutting down, GT1 still power on).
Before CE, I use custom ROM AndroidTV and Kodi, the power button (of Samsung remote) working fine. Bad thing is TrueHD and DTS-HD is not passedthrough. Have tried shitty build (no sound at all) and forceraw build (no TrueHD and DTS-HD MA)

When install CE, TrueHD and DTS-HD is passedthrough (great), but power button does not work.
So how do I resolve this issue?

Is my problem related to uboot, or device tree?
Coz I tried with LibreELEC, Samsung smart remote can shutdown (power menu appears) but can’t power on GT1 Ultimate. Wifi can’t be detected (on LE), probably AP6255 driver is not included.

You probably need to setup your remote. Nothing to do with device tree.