GXL p231 devices. NG test build

I’ve not had much time lately, but did get a chance to give the dtb for GXL p231 devices on amlogic-NG an other go.

If somebody with such a device can test the following build and give some feedback that would be great.


1 Like

Would this build be for KI pro?

This is for users that had issues booting their GXL based devices with the experimental support for these devices in the current stable builds. In particular anybody that used a dtb for their device that had p231 in the file name.

K1 pro is based on the p230 reference hardware so there is no changes for it in this build. If there is outstanding issues with k1 pro, please either point me to an existing thread documenting them or create a new thread about it.

1 Like

Are all the devices in this list updated:

If so I tried the gxl_p231_1g_m8s_dvb.dtb but didn’t get the thing booting.

Yes all the p231 should be updated. I don’t actually have one of these devices, so I had to go off of what seemed to work for the p230 devices.

Did you do the hold the reset button thing or what ever your device needs on a new install? The boot script is different with the Amlogic-NG builds, so it won’t boot the first time with out that.

There may still be some issues involving the 1g devices that may take some further effort as well.

edit: if you have the ability to and the comfort level to access the uart on the device and make a boot log, that may help me sort out the issue. if you don’t/can’t then it’s possible somebody else maybe be able to do so with their device.

I just use an new USB drive to boot. There is no reset button and I don’t have a serial cable.

You can try the SDIO board if you want to help by providing a UART log.
There is no need anymore to open the device for a UART.

Unfortunately still no video output on KII Pro 905D, same as

This device doesn’t have SDIO. I can probably use a PL2303 or CH341 USB UART but I don’t know if the kernel is built with those modules.

Does your device have a micro SD slot? The SDIO board is a external adapter board what can be insert into the micro SD slot of the device. There is no need for a UART driver on the Amlogic device.
You only need a UART adapter to connect the SDIO adapter board to a terminal, what can run on any other hardware you want.

No, it doesn’t have an SD slot. It only has HDMI 1.4, two USB 2.0 and antenna input and power. I rebuilt the kernel with PL2303 and CH341 support.

The the SDIO board can not be used. To add the USB drivers will not help you.
You need to open the device and search the TTL-UART pin header and connect you UART adapter there.

I do not know you exact hardware but almost every Amlogic device do have a UART header like this example:


Thanks but I haven’t had the need to open the box up yet. Anyhow I compiled the kernel with PL2303 support. Hey that pic seems to show the need to solder a header or something on there. I am not very good with a soldering iron. I think I rip the pads or vias off.

USB support is present so this should work. It has worked on other embedded devices. So I will try this first and get back to you.

You will not get a UART log by the USB connection, you need to use the inbuilt UART pin header or if possible the easier to use SDIO adapter board.
When you compile in the USB driver you can use your USB-UART adapter and your device as host, not as target.

Sometimes it’s enough just to carefully fix cables in this pins if possible

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice