H96 Max S905X2 working Coreelec

I had similar issue with an SD card.
One im using is an old 8Gb class 4. Works a treat :slight_smile:

H96 Max is a very good Android TV box, which supports 4K video output, making the TV screen feel like a movie theater. But after a long time, there will be some problems. This is a common problem of Android system, so you need to clean the cache of TV box regularly. Do you have any problems?

I haven’t cleaned the cache yet.
Might have a look how to do it but not having issues I know of…yet.

1 Like

There are not many common problems with Android boxes. This article, [taking H96 Max as an example,] points out seven common issues. You can learn about them.

Hello, right now installed latest https://relkai.coreelec.org/CoreELEC-Amlogic-ng.arm-9.2-nightly_20191220-Generic.img.gz on H96 max x2 and seems like it has some hdmi or colorspace problem. Colors are pink. LIke some colorspace is missing or something. Starts with coreelec booting logo and continues in KODI. If I boot android everything is OK. Any idea?

Please refer to this:

1 Like

Thanks this helps! :slight_smile:

So I just recently got my hands on a H96 Max X2 (4GB RAM, 32GB ROM) and got CE installed on it using the latest stable generic S905X2 image (9.2.1) and device tree 4G (installed to internal using ceemmc). Everything works beautifully, except for the following minor annoyances:

  1. Some menu items in the Estuary skin randomly disappear after a while - this one is minor as I can resolve by switching to another skin and switching back.

  2. This one is major and has pretty much ruined the experience - no matter if I am using ethernet of wifi, the max speed I get is around 7Mbps both upload and download (using the speediest add-on installed from the Kodi repository). When I run a speediest on my phone on the same wifi network I get 100+ Mbps. If I pull the ethernet cable out of the box and plug it into a laptop and run a test, the speeds are much higher as well. I am stumped - any suggestions?

I only use ethernet. Speed test gives me approx 70 on my 100mbs in off peak times.
Only drops pretty low when there is congestion.

You may need to disable wifi in order to test ethernet speed.
Also, this is unlikely to be a CE problem, but rather the limited wifi capabilities of the box or the addon you are using.
Try iperf.

Appreciate the response, did some more testing today.

WiFi is disabled. Only connection is Ethernet.

When I run a speed test on my laptop using Ethernet, I get about 130Mbps download - I then unplug that cable from my laptop and plug it into the H96 box and run a speed test and it caps out just under 8Mbps download. The box Ethernet is 10/100M so I’m not expecting the full 100, but certainly not as low as 7-8. If I unplug from the box and plug into my laptop again I get the full 130Mbps again.

I’m not familiar with iperf yet, but will read up on it and try it out during the week.

Could this have something to do with Ethernet drivers on the box?

Highly unlikely. iperf lets you test your local network throughput. You need another PC or device to test with, should be wired for best performance.
You’ll need to install the Network Tools addon to install iperf on CE.

Already installed the Network tools addon, will try to figure out iperf over the next few days.

As a side note, I got my hands on another brand new android box (Viden M16). Booted up android and ran a speed test using Ethernet - 92Mbps. Rebooted to CE on SD card - 9.2.1 stable - turned off wireless and ran a speed test using only Ethernet - 7Mbps. Tried again with latest nightly, still 7Mbps. Seems to me like CE is capping network speed at 7-ish.

Much more likely it’s just something with the speedtest addon, perhaps on these devices.

Don’t use speedtest addon in CE, it could show not correct values…
Install entware (🆕 Entware package manager )
Execute this commands

opkg install python python-pip
pip install speedtest-cli

And after you can use speedtest-cli command for correct internet speed tests

Im currently using the Arnu Box addon . Seems to be reasonably accurate compared to my pc results.

Edit: See below… thanks to Kostaman I re found the link in the Kodi repository. cheers

At least use the Speedtest Addon from Official Kodi Repo.

Or SSH into your box and run command below.

curl -s https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest.py | python -

OK I initially thought I was, thanks.
Same looking . Must of been blind. Have removed linky above.

How is the status of CE when it comes to this box? Does everything work from the box after installing CE (remote, lan etc etc) or do I need to configure remote files?

Just set up a 2nd box. Working ok from 1st boot.
Used latest release9.2.1 and remote file as in 1st few posts above.