H96 max x3 - Slow wifi and not run resolution 4k max 30hz

Hello. How to resolve on box H96 max x3 slow wifi? Slow on CoreElec. On Android system not problem. And not run resolution 4k max 30hz (HDMI 1.4 - 4k passtrough). CoreElec 9.2.7

I try new version 19 RC1. Still Wifi slow. Resolution FHD not 4k.

Can you check in settings-system which resolution is chosen and if you can change to 4k there?

I can change on not function (black sreenn). Framerate not change to 29.97hz

I tried 9.2.7. stable and nightly build. tried 19. Still wifi slowly work. In Android wifi run normally.

On CE-19 there is a option in CE settings/device tree: WiFi SoC SDIO Speed
Maybe you try to change it and test again if it changes.

If not please dump your Android dtb by:

I test change WiFi SoC SDIO Speed in setting. Wifi still slow.
dd if=/dev/dtb | gzip > /storage/downloads/dtb.img.gz No work.
dd if=/dev/dtb | gzip > /storage/dtb.img.gz Work. I file is no find. Where is it?

dtb.img.gz (199.2 KB)

Change the box to X96 Max+ q2. Wifi and bluetooth not work. I plug ethernet cable. Still not work resolution 4K 30Hz and 4K movies. 4k movies down box. I must unplug dc adapter cable.

CoreElec not support 4K pass-through from Av receiver with Hdmi 1.4? Android system is support.

My avr not support color depth 4.4.4. only 4:2:2. I activate on settings and now resolution working.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.