Hauppauge HVR 1950 USB

I have a Hauppauge HVR 1950 USB that doesn’t get installed to /dev/dvb during boot with CE19 but it is fine with LE10. Does the CE kernel support pvrusb?

[   86.318083@2] usb 1-1.2: Product: WinTV
[   86.318086@2] usb 1-1.2: Manufacturer: Hauppauge
[   86.318087@2] usb 1-1.2: SerialNumber: 7300-00-F078D507
[   86.319242@2] usb 1-1.2: Unsupported device


Have you tried to install crazycat or latest kernel driver’s modules? You’ll find them at addons->services. After installation you’ll find a module selector in the addon’s tab at home page.

Yes I tied both of them but still get unsupported device. That is why I thought it might be pvrusb2 related



LibreELEC:~ # ls /usr/lib/kernel-overlays/base/lib/modules/5.10.35/kernel/driver
as102         dvb-usb       pvrusb2       ttusb-budget
au0828        dvb-usb-v2    siano         ttusb-dec
b2c2          em28xx        stk1160       usbtv
cx231xx       hdpvr         tm6000        uvc

on CE

ls /usr/lib/kernel-overlays/base/lib/modules/4.9.113/kernel/driver
airspy      cpia2       em28xx      pwc         stkwebcam   zr364xx
as102       cx231xx     gspca       s2255       tm6000
au0828      dvb-usb     hackrf      siano       usbtv
b2c2        dvb-usb-v2  msi2500     stk1160     uvc

not supported, sorry.

Is it a v4l thing with Amlogic or is there a way to manually rebuild the kernel to enable it?

# Analog TV USB devices

I am sorry to disappoint you but we currently don’t have the resources to support DVB. In fact maybe with the next major CE 20 release we might drop all drivers not supported by the then used Kernel which will be newer than 4.9.

I understand and fortunately the driver I want is in the kernel. I just was hoping to be able to enable another kernel config option to build CoreElec myself.

The info we found is that it requires a more recent kernel than 4.9. Correct us if we are wrong.

My primary Debian Buster backend is running 4.19 and I see it is there


If I install Armbian N2 Buster with the 4.9 kernel would that tell you the information you need?


I just wanna know where this comes from. I use Debian for my system myself but 4.19 is quite not near 4.9 if you can understand. There are worlds between them.

Really sorry I wasn’t thinking, I thought it was 4.1.9 pvrusb is very old though I find references back to kernel 2.6.18

In any case would testing with Armbian 4.9 give any clarity?

Internally we discussed it and it seemed I misunderstood and 4.9 kernel is supported. No idea it that works.

@emveepee please have a try with this test image:

no idea if it will work…

Thanks for that it does need pvrusb

[   34.721621@3] pvrusb2: Hardware description: WinTV HVR-1950 Model 751xx

pvrusb2               217088  0
tveeprom               24576  1 pvrusb2
cx2341x                36864  1 pvrusb2
dvb_core              147456  1 pvrusb2
v4l2_common            20480  5 tuner,cx2341x,amvdec_ports,pvrusb2,cx25840
videodev              307200  10 tuner,cx2341x,amlvideodri,v4l2_common,videobuf2_common,amvdec_ports,pvrusb2,v4l2_mem2mem,videobuf2_v4l2,cx25840

Unfortunately it faults http://ix.io/3uqH so don’t spend a lot of time on it. I tried the 3 all sets of firmware.

Yes, I think without the hardware in the hand it would not be possible to solve the issue. There are some few commits on this driver in mainline kernel what one maybe solve it. Maybe when the new kernel will come up someday it start working.

Case closed

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.