Hdd and CoreELEC

can i install coreelec to external hard drive and boot off of it rufus does not see it is there other software that i can use to install on external hard drive

Yes you can.

In Rufus select the option to ‘show advanced drive properties’ where you will find an option to list USB hard drives, where you can select yours.

i did that and loaded corelec to hdd and now the cumputer doesnt see the hard drive

When you burn CE to the drive it will create 2 partitions, one of which can be seen in Windows to enable you to move the required DTB and one that cannot, which normally results in an error in Windows to the effect that you need to format the drive, which you can ignore.

Sometimes though, Windows may not assign a drive letter to the first partition, but you should be able to use disk management to assign one for you to see.

I have run CE from an external SSD, so I know that it will work.

the gt king could see the drive and was able to rename to dtb.img and the drive booted core elec awesome lots of storage 1tb :smiley:

Hello,

I installed CoreELEC 9.0.3 to an external hdd, and I’m trying to boot on a Mini M8s box (S905), but with no success. The same instalation on a USB flash drive (8gb) can boot.

Do I need to do any special step to get the box to boot an external hdd? Thank you!

Have you read @Compent’s replies?

Yes, I read them, but they don’t seem to cover my issue.

I could use Rufus to install to the external hdd, and I copied the correct DTB. I then repeated every step, this time with a USB flash drive. The HDD does not boot, and the flash drive boots. They contain the same data, they only differ on size, and something else that I don’t know.

Are trying the same USB port?

Yes, I am. This box has 2 ports, and I know for sure the one that boots is the rear one, although I tried both, just in case.

I’m not sure if it will work for you but since recent rufus/windows updates I can only successfully write and boot CE from usb/sd/hdd when I run rufus as administrator on windows10.

Just tried that, with no success. I am also using latest version of Rufus on Windows 10. Next step is to try on a Linux machine using dd.

On Win 10 use Etcher. Works perfect with HDDs

It’s also worth checking the HDD for existing partitions that might not have been wiped.

I myself would use a partitioning app to wipe all partitions and then format the drive to FAT32/NTFS before proceeding with burning CE.

Hello. Nothing worked for me, not even using a diferent HDD. I’m giving up on this, and will install on a SD and use HDD as storage. Thank everybody for all the help!

Hi im trying to run coreelec on mini m8s but cannot boot i have firmware from levvy, and there is twrp, in android im rebooting to recovery but no coreelec loading ?
How to boot from usb on this box ?

Btw I had problems with rufus.Etcher made the trick.