HDMI-CEC Problems Odroid C4 / N2 / N2+

Thank you very much! I will install the one with debug prints right away. What should I do if it CEC stops responding? Which command should I execute in SSH?

Right after it happen and before reboot:

journalctl -o short-precise | paste
cat /storage/.kodi/temp/kodi.log | paste

Please place also this advancedsettings.xml in userdata folder where the other xml are located.

1 Like

I installed new image including debug prints from CEC .Cannot get it to crash as it always does!!! Normally it just stops responding and the TV don’t change to other CEC sources like Chromecast in HDMI1. Tried everything and will continue testing. Did you change something to fix this CEC bug? At the moment no problems at all. Will test it today the whole day.

:crossed_fingers:

It seems that the bug is fixed… I cannot reproduce it anymore… Will test more… Can you briefly explain what was changed? It is beyond my imagination but I still would love to know.

I only “optimized” the driver a bit to perform better when libCEC is used. I will move the changes to nightly for more tests. Please update tomorrow with the nightly again.

Thanks for testing!

1 Like

Thanks a lot! Now i can probably move to the next construction : bluetooth problems with coreELEC settings addon. But this is really fixed, no problems anymore. I want to thank you once again! I don’t have to replace my TV now.

http://ix.io/2MBA
http://ix.io/2MBB
After I have changed to Chromcast (HDMI1), watched a short video and switched back the Odroid the device restarted but it is not a big problem for me. After restart everything was back and CEC operational.

Now i have added the echo 1 > /sys/class/aocec/dbg_en to autostart.sh again so i will not forget to execute it after each restart of the device.

Happened again at 0:02 when i tried to update the content of the folder on the network:
http://ix.io/2MCK


I don’t know if you see anything important.

Maybe something about your spotify addon.
Also there was a change last nightly about librespot.
Please try again with the new nightly. I do not see any “hard” error.
Does Kodi freeze? Does CE reboot?

It did not freeze. Just the CEC stopped working using TV Remote. Also it was not possible to change to another HDM-CEC device like Chromecast. I will futher test and observe. Maybe it also has something to do with CoreELEC Settings addon which sometimes becomes extremely slow and sometimes the system says that the addon is not ready. I now installed the debug version of this settings addon as vpeter asked me to do. i deleted the settings of the coreELEC settings addon before. I have installed the nightly from 200121 and will test.

This can be happen because of BlueTooth.
So I guess we have here another issue.

The current used CE settings are from 9.2 and aren’t uptodate anymore.
But the new version from LibreELEC does even work less and we need to wait until it get ready for user community.

1 Like

I have unpaired the paired bluetooth devices, disabled Bluetooth service in CoreELEC settings and pulled out the Bluetooth dongle. I am waiting for a working addon for that. Will continiue testing CEC, thanks for adding the commits to the nightly.

I don’t know if it will get fixed ever on 9.2 :innocent:

1 Like

does it work better on the kodi 19? :slight_smile:

do you use last nightly or my test build? please update to nightly, there was a fix about librespot/spotify.
this fix is not included in my test build. the CEC fixes are already in the nightly.

1 Like

Using the nightly from 200121. Let’s see it how goes.

Still happening but not that often. (only when pressed the buttons continuously, like scrolling) I will try the CE 19. It is definitely better than before. Thank you for your work!

Maybe you leave the debug logs running and I can find another issue…

I didn’t had any issues anymore since last changes here.