HDMI CEC stopped working


My CEC has been working fine. Today I tried to use the TV remote to operate CoreElec to no avail.

Tried a reboot, turned off and on the TV etc etc

Is there something I can do to kick-start this?

Any help would be appreciated. No idea why it’s just randomly stopped working.


Sorry. Switched everything off for 10 mins and it’s fine now.

For me, sometimes CEC stop working after switching back and forth to another hdmi sources.

I have to reboot the box to reactivate CEC again. I don’t know if this is CEC bug or it’s just my TV problem.

If you have another Chinese Box plugged into the TV
It is known that some of them will block CEC to other HDMI sources.

Exact same problem for me from time to time. Happened on the RPi as well, and on different Kodi distros. I think it’s a TV problem.

Also if you leave Kodi running the CEC will not get initialized new if it have too. Only a restart of Kodi make a new CEC connection. So if you turn off the TV and not the box it may happen that the connection cannot be established again. Best is first power on TV, then the box. Or use suspend mode with Kodi.

So I just discovered this after almost throw my tv away. I saw arc stop working, and by chance i figured it out after removing all hdmi cable and readd one by one. So i now remove the s905 from outlet when not using. Is that something we can expect a fix or one of those thongs we will neee to leave with it?

You need to change the bootloader of your device. But most of the box has no source for it, so it is not easy to fix.