Headless CoreElec crashing

I am trying to test CoreElec headless on an HK1 S905X4 but for some reason I get power input messages and a crash/reboot cycle

http://ix.io/48Ri
http://ix.io/48Rm

After connecting HDMI it works any suggestions on getting this working?

Martin

I had the HK1 RBOX X4. Mine is crashing too. Done extensive troubleshooting and nothing seems to help. I think I got a faulty box. Seems like HK1 is a very low quality tv box.

Mine would crash randomly and can’t even install apps with bigger file size. Mine is 64gb and I could not install games like real racing as it says I don’t have enough storage while I have more than 55gb empty. It’s just a crappy in my opinion

That is probably unrelated, mine will always crash/reboot when HDMI is not connected but it is otherwise stable ie can play Live TV for hours.

Maybe related to EDID not readable w/o HDMI connected to TV.
You could try to make a local copy of EDID. With TV connected, ssh into CE and execute:

cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata/disp_cap

Ok I tried that and it still crashes reboots with this log http://ix.io/493d

cat .kodi/userdata/disp_cap    
480i60hz
576i50hz
480p60hz
576p50hz
720p60hz
1080i60hz
1080p60hz*
720p50hz
1080i50hz
1080p50hz
640x480p60hz
800x600p60hz
1024x768p60hz
1280x800p60hz
1280x1024p60hz
1600x900p60hz
1680x1050p60hz

Did you mask Kodi service?
systemctl mask kodi

@Portisch that seems to avoid the crash which likely was being caused by the continuous stream of phantom keys These continue until I plug in the HDMI http://ix.io/49fj

I think I have seen this error before, about fops_vcodec_release.
It’s something we do not use but I don’t remember how we fixed it.
Or it was something about enabled in dts what should not be enabled.
Did you try with a fresh clean install without any modification.

I searched a bit the history and the error was related to dvb stuff.
And your log shows the dvb-latest or crazycat is enabled.
Sorry, disable them or contact the author.

OK I will try with a clean that I use 7Ji’s patch for the S905x4 to so that eth0 can be downed properly and get a clean shutdown power up.

I was thinking it was cec related, with cec trying to power on HDMI in journalctl I see this repeating

Aug 31 09:13:54 CoreELEChk systemd-logind[3475]: Power key pressed short.

No point in disabling dvb since the point of running headless was testing this as a backend PVR for NextPVR. There are no /dev/dvb devices plugin in though.

CE-19 or CE-20 do have the dvb addons. Just remove them completely and it should not crash anymore.

I don’t have crazycat installed only the one that says DVB driver from the latest kernel which I think I need for firmware. I am talking running the backend server as a service not the pvr.nextpvr (which needs Kodi) using my PR NextPVR: add new addon package by emveepee · Pull Request #6853 · LibreELEC/LibreELEC.tv · GitHub

Without hijacking your thread, why do you choose NextPVR vs Tvheadend? Perhaps you can start a new thread.
thanks

Yes it is real hijack and I will have more to say on that if CvH approves my PR. Being the prime contributor to pvr.nextpvr it wouldn’t makes much sense for me to use a TVHeadend backend.

On topic there is a use case to run CE headless for servers so I hope this can be figured out.

OK this is a fresh install to SD, no addons at all and it still loops on the input http://ix.io/49gR

If I stop Kodi and pull HDMI there are no issues. I do see this

[ 56.677483@1]- cectx fe044000.aocec: CEC framework ctrl disabled

Is there anyway to do that from the command line?

Don’t think so. It’s a ioctl call to the driver. So you will need to change the driver source. I don’t know if it’s possible by sh script to make a ioctl call.

Maybe disable the aocec node in DTB?

That didn’t work or at least using this didn’t

fdtput -t s /aocec status disabled

I am back to the nightly and just it case it isn’t clear in my other post because of my JL2101 chip I need the stmmac changes from here jl2xxx: add driver for jl2101 ethernet phy by 7Ji · Pull Request #12 · CoreELEC/linux-amlogic · GitHub or I can’t toggle off/on my box with the remote but either way the HDMI issue remains.

With the same stock nightly SD card in the Tanix X4 I used above except with the 100Mb dtb there are no issues with headless mode so it is not a general s905x4 issue. It could just crappy devices. Here is the Tanix log headless http://ix.io/49hR