Help with CoreELEC post-install quirks

Hey all, I made a post earlier about fixing my S10 mini box where I restored a custom Android firmware in order to then install CoreELEC, box info below:

  • Model: S10 mini
  • CPU: Amlogic S905W, ARM Cortex-A53 (4 core)
  • GPU: ARM Mali-450 MP (5 core)
  • RAM: 2GB
  • ROM: 16GB

After having used the burning tool from Khadas on Linux, I grabbed CoreELEC 20 Matrix, burned to an SD card and booted it on my box, but it turns out that connecting to my home WiFi gave an error, it said something about an input/output error, or it would just freeze & crash Kodi, which was strange since my WiFi used to work before, I tried connecting and reentering the password several times and nothing changed.

I tried the 19.5 final release, same thing.

I checked and on my last post, I used the following CoreELEC release:

  • CoreELEC-Amlogic-ng.arm-19.5-Matrix_rc2-Generic.img release
  • gxl_p281_2g.dtb device tree

I went back and tried that release again, on that one I was able to successfully connect to WiFi! Then it automatically downloaded and installed the update to the final 19.5 release and rebooted, after which not only did the WiFi still work, I was also able to use ceemmc to install it to the box!

Just some quirks I noticed so far:

  • The WiFi not connecting on 19.5 and 20.0 releases even though 19.5-rc2 worked
  • The edges of the screen are not fully visible playing a video from file manager
  • LED display on the front of the box does not work at all
  • Included IR Remote not working ootb, box/remote model are obscure ones so I will probably have to make my own remote.conf/KEYMAP if I understand

On point 3, unfortunately there still doesn’t appear to be an official OEM Android image to fix it if that’s what is necessary to fix, I did previously flash a possibly incompatible Android image even though the hardware was identical.

CoreELEC works perfectly fine, I ran the ir-keymap command listed in the remotes wiki and that was able to detect button presses from the remote so I might be able to work with that.

Not sure what to do about the player resolution, after installing I switched it to a different TV and booted into the main screen, edges were not fully visible and resetting the resolution fixed it, then changed TV back and resolution for main screen seemed off, reset the resolution again but once I played a video via file manager from sdcard for the first time I immediately noticed the edges weren’t fully visible for the player interface at least since the time was partially cut off, pressing ESC several times while playing the video brought me to the main Kodi screen which looked different than before I played a vid, I had not messed with video settings for the player yet.

I doubt this helps but here’s some pics of the actual box and remote if you’re curious:

I figured out the remote now, using the KEYMAP file sample from github got me most of the way there since a lot of the key mappings were applicable to the remote I had, here is my current config:

# table S10M_S905W, type: NEC

# box power key
0xdf1c KEY_POWER

# tv control keys
0xdff1 KEY_POWER2
0xdff2 KEY_EPG
0xdff3 KEY_MUTE
#0xdff4 voldown key for tv?
#0xdff5 volup key for tv?




0xdf5f KEY_HELP

0xdf42 KEY_HOME
0xdf0a KEY_BACK

0xdf1a KEY_UP
0xdf47 KEY_LEFT
0xdf48 KEY_DOWN
0xdf07 KEY_RIGHT

0xdf06 KEY_ENTER

0xdf03 KEY_INFO
0xdf18 KEY_MENU

0xdf54 KEY_1
0xdf16 KEY_2
0xdf15 KEY_3
0xdf50 KEY_4
0xdf12 KEY_5
0xdf11 KEY_6
0xdf4c KEY_7
0xdf0e KEY_8
0xdf0d KEY_9
#0xdf41 globe key?
0xdf0c KEY_0
#0xdf10 delete key?

In the above picture of my remote there’s 5 blue keys at the top, seem to be control keys for the TV rather than the box, don’t know how or if that works.

Of those 5 blue keys:

  • The blue power button I mapped to KEY_POWER2 (since the red power button is KEY_POWER), however it doesn’t seem to do anything
  • The blue btn on the left was mapped to KEY_EPG
  • The blue btn to the right of that one was mapped to KEY_MUTE
  • The 2 blue btns to the right of that one aren’t mapped and appear to be voldown/up keys for the tv rather than box, there’s already separate volup/down for the box

Then I mapped the “HELP” button to KEY_HELP, on the bottom left there’s a globe button, and a button on the bottom right that looks like some kind of backspace button but mapping it to KEY_BACKSPACE doesn’t seem to make it behave like a backspace button when entering text in CE.

Remote works pretty well otherwise.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.