Help with VFD.conf

That’s too bad. Does the display behave any different with this vfd.conf compared to the other ones?

It does not. I tried about 6 different ones and the display is always blank.

Is there any way I can reload the .conf from ssh without rebooting?

You can do that with this driver + script.
Extract it in downloads folder, then use sh to rerun the driver or sh to disable it.

I think I figured out why it wasn’t working. (at least I hope I did).
Can you try this driver and see if it works? (30.0 KB)

Hey! I know this is kinda old, but I’ve a similar issue. Used your tool to load the latest m9-pro-u2c-x-u5x-s-vfd.conf, but I can’t get it to work. I’ve a U2C Z Pro (2/8GB, S905X):

Update: I found a dtb.img similar to my device. Someone over here contacted the official u2c seller on amazon and got the official update file, containing the dtb.img. I’ll contact them, since mine is a U2C Z Pro, not U2C X Super, but the display look exactly the same (without BT).

What’s not working? Is there nothing on the display or is it messed up?
You can probably extract the DTB from your box yourself. You need to boot into Android for it:

I already gave some more details in this thread: LibreELEC - (VFD) Displays in LibreELEC

I got my dtb.img extracted:
What should I do with it? I tried to create a fresh boot sd and replaced the original, with my dtb.img file, but it won’t boot and stays black.

The display simply stays black, regardless which vfd.conf i use. OpenVFD AddOn is installed

You don’t need to change DTB files. Stick to the DTB file that works for your box in the device_trees folder on the SD card.
I’ll look at the Android DTB to see if it has the configuration for the VFD.

Do you found anything? I’m patiently waiting for your reply…

Yes, the VFD configuration is different.
Can you try this VFD and see if it works?
u2c-z-pro-vfd.conf (1.5 KB)

Yes! It worked. Can you please explain how you converted my .img to a .dtb file? I read about using the dtc tool for this:

How to convert it?

Great! Do all the digits and icons work and are they in the correct positions?

To decompile a DTB file I use the following command (you need to install dtc)
dtc -O dts -I dtb -o filename.dtb filename.dts

Edit: The DTB file you posted is a multi-dtb file. I had to open it with a hex editor, and cut out just a single DTB file from it. It usually starts at address 0x0800, and then you cut it off after a section of strings followed by a lot of 00s.

That explains what he’s doing in this video. :slight_smile: Thank you. I’ll have a look at it.

At first LAN, Wifi, Time and HDMI worked. Then I placed my personal .kodi Backup in /storage/ and it only shows the current time. Tried rebooting. Which file do I need to keep in .kodi if I replace this folder? Migrating from LibreELEC on Raspberry Pi 3.
Got it: Forgot to reinstall OpenVFD…

How to check if AV works? Currently testing SPDIF. Can’t test if BT works, since I’ve no BT USB stick nor onboard BT.

BT and SPDIF monitoring is currently not supported, but you should be able to use them as a storage access icon.

Hi TheCoolest,
I realize this is an old thread, but I cannot get the vfd to work at all. I have a Sunvell T95Z Plus device, 32 gb rom / 3 gb ram. What do I need to do, tried several dtb files, even .vfd files I found in forums to no avail. I have wiped the original Android but have a copy of the original one, in case extracting a .dtb file is possible from the image. Please, would really love to use coreelec on this device, but fixing vfd and configuring the remote seem like the outstanding issues, maybe getting it to turn off the led anode as well when it is turned off, but that is no big deal after all. Let me know what to do in order to be of any assistance so that you can help me. Thanx

Hello everyone, I’m new here and I am asking for your understanding.

I have the same problem with the Sunvell T95Z Plus device, 32 GB ROM / 3 GB RAM. What I have to do, I tried several dtb files, and the vfd.conf file.
The display remains dark and the LEDs are constantly lit.
The blue led box is on, the blue and darker led box is off. The remote works

i tried different dtb tree. there was no difference

Run the following command in Android, and post the output (you can take a picture with your phone)
cat /sys/kernel/debug/gpio
Like this:

I am green in this topic, you can explain it to me exactly. Thank you

I have checked remote control now and it doesn’t work 100%