HK1 Box Amlogic S905X3

Hi all,
I usually buy for friends & family tv box where I configure coreelec. I used to buy x96 and hk1 tv box. Recently, I have bought 5 HK1 tvbox from this link Amazon HK1 and I have realized that in all of them, there is no way to conect throught Ethernet.

I thought it could be the device tree file. Maybe they change anything and ethernet wasn’t 1GB but 100M… but still, it doesn’t work.

However, if I start the tv box in Android, ethernet works just fine.

I got some support from a telegram user. He recomend to me to install “Device Info HW” in Android, so we can see the hardware specifications of the HK1.

Curiously, when opening that app, in the general view, it doesn’t show it has an ethernet connection, but I can guarantee you, that I am connected on Android throught ethernet.

I have at home a x96 device, and running the same app, in the general tab, it shows I have ethernet.

So… my problem is that:

  1. I have ethernet connection in Android
  2. Using a hardward info app in Android, it doesn’t show I have ethernet
  3. When running Coreelec from a SD Card, there is no way to connect with Ethernet

Any suggestion or solution?

Just one thing more. In coreelec, when going to setup and lan connection, it is not enable. There is no way I can put it on enable mode. That happens using “sm1_s905x3_4g_1gbit.dtb” device tree. If I use “sm1_s905x3_4g.dtb”, I can put in enable mode “lan connection”, but still… there is no connection throught ethernet.

Thanks in advanced.

Read forum…

But mine is s905x3, not s905x4…

HK1 Box Amlogic S905X3 64-bit Quad Core with Dual Wi-Fi


Hardware Specifications

Chipset: Amlogic S905X3 Quad Core ARM Cortex A55 @2GHz
OS: Android 9.0
Memory: DDR3 4GB
Flash: EMMC 64GB
WiFi : 2.4G +5G
BT: 4.0
Power Supply: DC 5V/2A
Power Indicator (LED) Power ON: blue;

Main Features

USB:1 High speed USB 3.0 and 1 High speed USB 2.0
VP9 Profile-2 up to 4Kx2K@60fps
HDMI: HDMI 2.1 ,Support HDMI CEC, Dynamic HDR and HDCP 2.2,4Kx2K@75 max resolution output.
Card reader: TF cards, Support 4GB/8GB/16GB/32GB
LAN: Ethernet:10/100 standard RJ-45
Medium: Local Media playback, Support HDD, U Disk,TF Card
Support DLNA function
Support 2.4G wireless mouse/keyboard

Please provide a log.

If that doesn’t work try the 2G (100MBit) edition and see if that one works.

Again, please provide a log.

I have tried with all 905x3 device trees with no success.

Find attached the log file.

Log file

Sorry, I did it copying the log file from the tvbox. I followed instructions provided and this is the short url with the log file.

The JL21xx chip needs the nightlies for CE19 and 20.

Apr 11 16:28:36 CoreELEC kernel: eth%d: PHY ID 937c4032 at 0 IRQ POLL (stmmac-0:00) active

Your log shows
Starting CoreELEC 9.2.8
Kodi 18.9…

You need to test latest Matrix Nightly
Or Nexus alpha nightly

Then should have success

Good luck

Happy Testing

2022-11-04 20:02:09.142 T:4065755200 NOTICE: Running on CoreELEC (official): 9.2.8, kernel: Linux ARM 64-bit version 4.9.113 aarch6

This version is no longer supported by Team CoreELEC: CoreELEC 9 (Leia) End of Life Announcement

Please upgrade to CoreELEC Matrix 19.5 RC2.

Be aware addon compatibility will be broken.

I have tried with Matrix with same result.

Find logs here…

That’s not a nightly though, as two of us directed you to.

1 Like

Please drop this in the CoreELEC update folder and restart the device.