Homatics Box R 4K Plus

I did try the power save menu but no good result. I would like to try the hack you pointed to but its a bit beyond me. I have ssh into my machine before to add keymaps but I had much clearer instructions for that. The way this is written assumes you know what your doing when in fact I don’t :anguished:

That’s not going to work, because we make changes to both Kodi and the kernel to make things work correctly. In addition, Android uses a completely different video pipeline, so it wouldn’t really work regardless.

LOL I figured it was too good to be possible or someone would have done it already.

It’s mostly copy/paste in the terminal and instead of vi to edit config file, use nano.

Nothing was changed in this area. And about what numbers you are talking about (5 and 10)? Where do you set this in CE (because I’m not familiar with them)?

The brightness in CE has values from 0 (LED off) to 4 which is max brightness. It is set by command in terminal

echo 1 >/sys/devices/platform/soc/fe000000.apb4/fe06c000.i2c/i2c-3/3-003c/leds/bct3236/brightness

and checked by command

cat /sys/devices/platform/soc/fe000000.apb4/fe06c000.i2c/i2c-3/3-003c/leds/bct3236/brightness

But this brightness is little confusing because when we set the color we also set the intensity of it.
Which consecutive set also brightness of the LED.

Color is set in DTB but also from terminal with command

echo 101010 >/sys/devices/platform/soc/fe000000.apb4/fe06c000.i2c/i2c-3/3-003c/leds/bct3236/edge_color_on

where 101010 is the default blue color.
This 101010 is represented as RRGGBB (red, green, blue) and we set the intensity of separate RGB LED. Values are in HEX form from 00 to FF.
00 is off, FF is maximal intensity.

Beside setting color for edge_color_on there ais also edge_color_off and edge_color_suspend.

You can add echo line to autostart.sh to fix your issue but I checked last nightly build and value is still 1 for me.

Would be good to understand what went wrong for you.

25 posts were merged into an existing topic: Homatics LED addon

I’m running into the following with the (black) B21 remote over Bluetooth on a Dune HBR4K+:

  • Waking the HBR4K+ from Suspend with any of the buttons (Power, Home, Back) doesn’t work. The TV’s remote can turn everything back on and CEC is functioning. I tested this with both a 2022 Sony and LG TV.
  • Volume Control over CEC doesn’t work. I tried with a Sonos soundbar and an Apple TV with HomePods. I tried going under Settings > Input > Peripherals > CEC to see if anything there would help, but it didn’t.
  • Sometimes the remote doesn’t seem to be reconnected over Bluetooth and I need to go under Settings > CoreELEC > Bluetooth and reconnect it.

Otherwise, this seems like a great little remote to be able to use with CoreELEC.

  1. I modified Homatics and add IR receiver and waking up from suspend worked with Power button on white B21 remote. That’s why I assume it should also on Dune.
  2. When this happen just try pressing pairing buttons on remote and remote should be working after that.
1 Like

Thats mean you can use the homatics in IR mode, in coreelec, with the remote. conf, and wake up and power off working? Cool.
My ir diodes still in transit… :slightly_smiling_face:

Could you clarify how this addresses what I had mentioned?


I use this remote.conf file on my DuneHD Homatics. It works fine with original B21 remote control in IR.

I bought a Nokia rc110 remote control (original remote control of Nokia 8010 box)
I tested it with my DuneHD Homatics box in IR. It didn’t work.
Can you send me the right remote.conf of Nokia remote control?
Or what do I wrong? How should i do right?

Does anyone have Power and Volume working over Bluetooth with the B21 remote (and controlling CEC devices)? This is ideally what I’m looking for since IR doesn’t seem necessary in my setup if given that Bluetooth has less latency and doesn’t need line-of-sight.

My Homatics uses my old Minix RF remote with its USB RF dongle without any re-programming of keys.

It does not pass-through Dolby Atmos TrueHD to my Denon AVR.

It get remote paired without going to go under Settings > CoreELEC > Bluetooth and reconnect it. At least it works for me and maybe it will work for you too.

Well, I think I was too fast with this answer (with too little thinking). Because on suspend USB port loses power the USB stick get remounted as different device. I’m still investigating the “proper” solution for this. Or maybe Homatics could do some change in Android to keep power on USB for suspend.

Which means only powering on from off state is supported.

Update: Maybe I do have a working solution. But storage must be used from eMMC with my instructions above.

1 Like

Thats enough for me :slightly_smiling_face:

btw. which one diode soldered? CHQ1838 or VS1838B IR diode

I just took one 38kHz IR receiver diode from one old project (TSOP38238).

1 Like

This is a good feature, is there any progress?

Hi, I was long time out. Please last time I ised image with lan problem solved but dont have now nothing updates. So may question is is new nigthly ce21 version without lan network issues? Thank you this version image I have now installed

Why don’t you update and check yourself? And you will see probably it is solved. But only you can confirm that.