Homatics Box R 4K Plus

Why don’t you update and check yourself? And you will see probably it is solved. But only you can confirm that.


I have tried to make a little add-on for Knight rider kit mode … But it don’t work . Can you take a short look on it ? Maybe it’s totally garbage…

How can I send you the add-on.zip ?

Upload it to https://wetransfer.com/ or some other free place?

Yeah. I can try it myself but also I can ask here,no? This lan network issue was other users too or only me?

Sure you can. But to give you the answer someone would first need to browse back to find out which device you have. Which I will not do. Changes are made daily so first try last image which exists. And if it doesn’t work let us know to investigate again.

Bluetooth acts wonky after coming out of suspend. Creating suspend/resume script seems to automate things.

cd .config 
mkdir -p sleep.d
cd sleep.d
nano restart_bluetooth.power
case "$1" in 
    # do something on suspend
    systemctl stop bluetooth
    bluetoothctl power off
    # do something on resume
    sleep 5
    systemctl restart bluetooth 

Maybe systemctl stop bluetooth before bluetoothctl would be useful too?

1 Like

How come suspend/resume working for me without the script?

It works. But after resume you probably don’t have /flash mounted anymore. Check with command after resume


/flash is mounted



Is B21 Remote Volume control (over Bluetooth to CEC) being worked on? Any chance this will be fixed?

What is to fix? I see volume changed in Kodi (at least I see top indicator). All good then?

I’m not seeing it communicate over CEC with LG and Sony TVs? I haven’t tested a nightly in a few days though if something was changed.

Why would communicate over CEC? It does local control of the device.

Your point is valid… is this an issue with CoreELEC then that’s unrelated to the B21 remote? CoreELEC should be sending CEC commands for volume control.

Looks like when booting from USB 2.0 port suspend/resume works better and stick is not remounted.

When booting from USB 3.0 port stick is remounted after resume with new name (sda1 → sdb1).

I use the usb 3.0 port and set the power saving menu to suspend after 2 hours. When I used the cec menu to enter suspend when tv is powered off, on resume sda1 is sdb1.

B21 changes volume on my receiver and soundbar. Both tv’s are lg.

I see the official Dune system is always outputing in Dolby Vision by default, even for the GUI. That prevents HDMI desync/sync but what about quality or correctness? Zidoo boxes have this option too, not enabled by default.

Good Day, I am slightly confused in setting up the USB as to which device_tree file to rename for the homatics 4k plus box to be renamed dtb.img, I did ask in the Homatics telegram and they intoned to use the homatics file but in the latest releases there is No homatics File… Ok so just talked to Sajid in the telegram thread and he said to use sc2_s905x4_sei_smb_280.dtb for Homatics so will give it a try.