IPTV Simple 21

I’m having issue with timeshift in IPTV Simple Client, if I paused it everything is ok but when I press a short rewind then CE (0421) freeze, sometimes unfreeze in about 5 min then reloaded IPTV Simple Client and sometimes i have to unplug then plug it in back.

It doesn’t happen in ATV same configurations and channels list except that in ATV I’m using IPTVSC 20.9.1 and in CE

If you need any log or test, just let me know which commands I have to follow.


Beside timeshift issue, I’m having problem with black screen (no signal) when I try to play some channels or stream videos.
Kodi log

Please install the Kodi 21 on your ATV (if possible) or on your PC, and see if it reproduces.
Kodi 21 is still in Alpha stage, it’s completely possible that the issue is with Kodi and not CE.

Thanks for your reply,
I don’t have any issues with Kodi 21 on ATV or PC with the exception they are using IPTVSC 20 while CE is using IPTVSC 21

Beacuse problem with InputStream RTMP dependency Im not able to update IPTVSC to 21 on ATV or PC

For black screen (no signal) if I go to Channels & Inputs settings on my Sony TV (XBR-85X900H) and change the HDMI signal format to any option (Standard format, Enhanced format, Enhanced format DV, Enhanced format VRR) then I get the image back from the channel, but when I switch to another channel, I have to do the same to get signal and so on. I usually have the Enhanced format DV by default.

Also I have to do the same for some third party video addon in some of the video streaming. I’m using Homatics Box R 4K Plus

With latest nightly build 0425 + sc2_s905x4_sei_smb_280.dtb, solved black screen (no signal) :slight_smile:

Still having problems with timeshift.

I tried it yesterday, works fine here.

I’m using IPTV merge in between since m3u4u doesn’t allow to load their channels list in Kodi. My channels are in .ts format. It strange cause it is working on ATV and PC with same channels list and configuration.

Now I’m facing another issue with Real-Debrid, I can paired the addon with RD but the stream doesn’t start. I checked Kodi log and it complaining that didn’t find secret key. It weird because it’s working in ATV, PC and in previous CE 21 (0421)

I got Homatics R+ too and I have same problems with timeshift and (edited-banned addon). Did you solve those issues?

What problem do you have?
In any case, please try this build and see if there’s any change.
This is an aarch64 21ne image. Don’t install it if you’re using arm deployment.


I explained the problem that I have in OP.
I’m using aarch64 21ne and this build didn’t fix the issue with timeshift

What about this image?

No, it didn’t work

Timeshift in IPTV Simple Client didn’t work for me either, but with this image the MLB plugin works fine.

with latest nightly 21 Homatics CE was freezing when I try to rewind or forward a game in MLB

Just to clarify. We are talking about timeshifting, not catchup. Correct?
I’ve been testing Catchup today, and after a small change it worked for me, but it looks like there’s some kind of problem related to threading and mutex locks.
We’ll keep looking into it, it could be an issue with recent Kodi changes, or it could also be somehow caused by a bad rebase of our code on top of the Kodi changes.

Yes timeshifting in live channel streaming not catchup. Please keep in mind that with @vpeter image MLB addon it’s working fine.

We verified that timeshift is broken on Windows as well, so looks like the problem is most likely with Team Kodi’s recent efforts.

It’s strange, I did tests on Odroid N2 with CE 21.Nightly-0505 and it works perfectly.

I think it’s just luck. We opened an issue with the Kodi team and they’re aware of this problem.

Any advance with timeshift issues?