Homatics Box R 4K Plus

CoreELEC makes the box a winner.

In terms of ethernet, I get around 700 Mbps. It’s not the Gig one would hope for, but way plenty for most use cases.


Nokia 8010 arrived today. I wanted to see what the Android TV looked like before I set up CoreELEC, but I can’t use it without a Google account? I’m stuck at the sign in screen. No way to skip. I also couldn’t go forward without connecting to the internet, so I plugged in my ethernet cable. Since I can’t get into Android TV, how am I supposed to check my firmware and update it in the future if need be? Well I turned it off and used the toothpick method to use CoreELEC.

Anyways, I don’t have a spare 3.0 speed USB with me so I had to use a 2.0 speed USB, burned CoreELEC-Amlogic-ne.aarch64-21.0-Omega_nightly_20230529-Generic.img to it using GNOME Disk Utility, copied sc2_s905x4_sei_smb_280.dtb from device_trees into the root folder as dtb.img. Plugged my USB into the USB 2.0 port, used the toothpick method, took a while to resize STORAGE (probably cause of the USB) but it successfully booted into CoreELEC. I’m in the welcome screen and I can’t proceed. Remote doesn’t work. AFAIK Nokia 8010 does have IR and Bluetooth. I tried a USB-C to USB-A cable on the USB 3.0 port and plugged in my DualSense controller, no dice, can’t navigate the welcome screen. Also tried with a DualShock 4 controller with a Micro USB-B to USB-A cable on the USB 3.0 port and doesn’t work. I’m stuck at this step.

Any help? Would appreciate a working remote.conf for the Nokia 8010. Also would like to know how to set up Android TV without internet and a Google account.

Edit: I enabled Bravia Sync (CEC) on my TV and am using the TV remote right now.

i am no expert so take anything i say with a grain of salt (:

1.) Android is not meant to be used without an account. Either you create an google account or you dont use android tv afaik only ChromeOS has a guestmode before setup.

2.) i used a wireless keyboard/mous with a dongle on the other usb port. (not the c) Homatics has 2 full size usb ports.
→ boot stick into usb 3 port and keyboard into usb 2 slot (c port empty)

bu i still am on stable so maybe there is a difference to nightly tho ^^

1 Like

Yeah, this must be something new cause with my X96 Max Plus I was able to skip/deny all useless prompts when setting up Android TV. Don’t know which version of Android TV it was though.

I will format and set up again when I buy another 3.0 speed USB. I’m just testing it today.

1 Like

Maybe because it’s not a certified Android TV box with an accordingly Android TV OS on it?

1 Like

Try this ,
Use meson IR mode.

ssh into Coreelec

systemctl stop kodi
systemctl stop eventlircd

Create a file
/storage/.config/rc_maps.cfg and put this code:
meson-ir * NOKIA

Create a file, name NOKIA to /storage/.config/rc_keymaps/
and put this code:

# table NOKIA, type: NEC
0xbf0d KEY_POWER
0x1d0209 KEY_MENU
0x1d025c KEY_HOME
0x1d0259 KEY_UP
0x1d0254 KEY_LEFT
0x1d0255 KEY_ENTER
0x1d0215 KEY_RIGHT
0x1d0251 KEY_DOWN
0x1d0219 KEY_BACK
0xbf0e KEY_MUTE
0x1d0213 KEY_1
0x1d0212 KEY_2
0x1d0210 KEY_3
0x1d0217 KEY_4
0x1d0216 KEY_5
0x1d0214 KEY_6
0x1d021b KEY_7
0x1d021a KEY_8
0x1d0218 KEY_9
0x1d021e KEY_0
0x1d0202 KEY_NEXT
0x1d0250 KEY_REWIND
0x1d0201 KEY_STOP
0x1d0208 KEY_INFO
0x1d020a KEY_RED
0x1d024d KEY_GREEN
0x1d020e KEY_YELLOW
0x1d020c KEY_BLUE
0x1d021c KEY_EPG

at the end ssh again :

ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
systemctl start eventlircd
systemctl start kodi

Thanks. Everything works except the volume buttons.

I tried Bluetooth before you replied, and some buttons worked while others didn’t, like the main button to enter/select stuff. While trying Android TV the remote also used Bluetooth, so I guess it is paired there, will that be a problem in the future?

I’ve gone ahead and disabled Bluetooth in CoreELEC settings. Interestingly the remote still works if I point it away from the device, even when I completely hide it. Thoughts? I hope it’s not using Bluetooth, although how could it?

Thanks for the remote instructions. Everything works great now!

This box, because of Coreelec, has everything I wanted.

you can plug your usb2 stick into usb3 slot :smiley: it will work

hm … maybe - i just was stupid when it booted first ^^

look here:

it was the answer i got and which helped me when my ok button did not work :smiley:

Also: i need to hold the two buttons for bluetooth pairing every time elec started so the remote actually connects :smiley:

So I’m trying to test some video and audio files on my Nokia 8010. They’re all on my external HDD. CoreELEC is on the USB 2.0 port. When I plug in the HDD to the USB 3.0 port, Kodi displays a Successfully removed storage: STORAGE and Successfully removed storage: COREELEC, which freezes the whole box. I have to unplug the power adapter, when I plug the power back in, it reboots into Android. I have to use the toothpick method again. When I try again with the HDD, same problem.

Nokia 8010

The HDD pull to much power and kill the power for all USB ports in the moment of plugin.

Solution: use external powered USB hub or USB Y cable with extra power connector.

Interesting, does not happen with my old X96 Max Plus when I plug in the same HDD. Are you sure it can’t be something else? Seems weird a powerful device like this is not able to supply enough power through a USB 3.0 port. Cause it works if I plug it in before I turn the device on. This is a regular external HDD btw, not one of these with external power adapters, although I do have one of those as well.

The same HDD on a different PCB with different components, yes, I am sure this is your problem.

if it is not an SSD and old spinning rust that it pulls alot of power.
using a usb cable with external power like suggested is the best solution.
Or a dock/hub which has its own power. Like the ones used as docking stations nowdays.

So is it a Nokia 8010 problem or Homatics/Dune/Nokia/RockTek problem? I’m just wondering if this is specific to my device or all these same devices. Can Homatics users chime in? Surely some you use external HDDs that don’t use a power adapter to watch local media. Does it crash immediately when plugged in? It doesn’t crash if I plug it in before I turn the device on. So it is able to supply power, it just crashes the whole box only when it is plugged in after Kodi has loaded.

I will try an external HDD with a power adapter and report back.

On another note, whenever I select the Reboot option in Kodi, the box reboots to Android instead of back to CoreELEC.

Hi, I have an Dune HD Homatics, and I try to connect by ssh with correct username and pass but when it connect in putty automaticaly close and show “Connection clsed by remote host” , i need help


have you enabled ssh in coreelec settings? it’s disabled by default
did you change the default ssh password?

user and pass:

had that problem yesterday on my x96air with -ng nightly. All of sudden after a reboot I was unable to ssh to it with that same error.
Tried everything, from setting a key, to changing the password. To testing an old locale fix.
I’ve found that I could send commands with ssh but I would not stay logged in. Deleted all the keys and rebooted and nothing helped. Tried downgrading some nightly’s as I was not aware when it started the issue and did not fix.
The only way to fix was to “downgrade” to stable 20.1. After that ssh started working fine.
Did not “upgrade” to nightly yet.

Hi there. Were you ever able to fix this problem? I also have the newest nightly and the Motorcomm option set, and no luck…